Bug 471731 - Yumex Error Type: <class 'yum.update_md.UpdateNoticeException'>
Yumex Error Type: <class 'yum.update_md.UpdateNoticeException'>
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
10
All Linux
medium Severity high
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
: 471786 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-15 04:46 EST by Didier G
Modified: 2009-01-06 05:17 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-06 05:17:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
updateinfo (548.02 KB, application/x-gzip)
2008-11-16 10:01 EST, Joshua Rosen
no flags Details
updateinfo (1.56 KB, application/x-gzip)
2008-11-17 08:00 EST, Joshua Rosen
no flags Details
rpmfusion-nonfree (860 bytes, application/x-gzip)
2008-11-17 08:02 EST, Joshua Rosen
no flags Details
rpmfusion free (1.60 KB, application/x-gzip)
2008-11-17 08:03 EST, Joshua Rosen
no flags Details

  None (edit)
Description Didier G 2008-11-15 04:46:46 EST
Description of problem:

Since November 13th, many users encounter the same problem : yumex fails with Error Type: <class 'yum.update_md.UpdateNoticeException'> 

Error messages are the following :

Error Type: <class 'yum.update_md.UpdateNoticeException'>
Error Value: No id element found
  File : /usr/share/yumex/yumex.py , line 737, in <module>
    mainApp = YumexApplication()
  File : /usr/share/yumex/yumex.py , line 446, in __init__
    self.setupYum()
  File : /usr/share/yumex/yumex.py , line 467, in setupYum
    self.yumbase._setupBase()
  File : /usr/share/yumex/yumapi.py , line 80, in _setupBase
    self._setupUpdateMetadata()
  File : /usr/share/yumex/yumapi.py , line 137, in _setupUpdateMetadata
    self.updateMetadata.add(repo)
  File : /usr/lib/python2.5/site-packages/yum/update_md.py , line 319, in add
    un = UpdateNotice(elem)
  File : /usr/lib/python2.5/site-packages/yum/update_md.py , line 69, in __init__
    self._parse(elem)
  File : /usr/lib/python2.5/site-packages/yum/update_md.py , line 146, in _parse
    raise UpdateNoticeException("No id element found")


Version-Release number of selected component (if applicable):

yumex-2.0.4-1.fc9.noarch


How reproducible:
Steps to Reproduce:

Every time Yumex is started

Actual results:

Yumex aborts with error above
Comment 1 Tim Lauridsen 2008-11-15 07:32:43 EST
try to do a 'yum clean all'
and start yumex again.
Comment 2 Tim Lauridsen 2008-11-15 08:35:24 EST
i have made a new release of yumex, there will handle these kind of error a lot better.

http://kojipkgs.fedoraproject.org/packages/yumex/2.0.5/1.fc9/noarch/yumex-2.0.5-1.fc9.noarch.rpm

they will hit updates-testing at next push.

but the main issue is that the update metadata is corrupted in some way, but yumex should be able to handle that and the new release should do that.
Comment 3 Joshua Rosen 2008-11-15 12:48:44 EST
yum clean all doesn't help.
Comment 4 Didier G 2008-11-15 12:57:40 EST
I installed yumex-2.0.5-1.fc9.noarch.rpm and it run fine.

Version number has not been changed and window tittle and About box still display 2.0.4 and not 2.0.5.
Comment 5 Tim Lauridsen 2008-11-16 09:26:22 EST
the version number is fixed in yumex-2.0.5-3.fc9.noarch.rpm :)

http://kojipkgs.fedoraproject.org/packages/yumex/2.0.5/3.fc9/noarch/yumex-2.0.5-3.fc9.noarch.rpm

there must be some problem with the update metadata, could you please
attach the following file
/var/cache/yum/updates-newkey/updateinfo.xml.gz

so i can check it out.
Comment 6 Tim Lauridsen 2008-11-16 09:28:32 EST
*** Bug 471786 has been marked as a duplicate of this bug. ***
Comment 7 Joshua Rosen 2008-11-16 10:01:04 EST
Created attachment 323719 [details]
updateinfo
Comment 8 Jason Farrell 2008-11-16 15:55:57 EST
yumex-2.0.5-3.fc9 fixed here.
Comment 9 Tim Lauridsen 2008-11-17 01:30:53 EST
(In reply to comment #7)
> Created an attachment (id=323719) [details]
> updateinfo

are there other update metadata files ?

ls /var/cache/yum/*/update*

the one you attached look ok at first look.
Comment 10 Joshua Rosen 2008-11-17 08:00:46 EST
Created attachment 323758 [details]
updateinfo
Comment 11 Joshua Rosen 2008-11-17 08:02:43 EST
Created attachment 323759 [details]
rpmfusion-nonfree
Comment 12 Joshua Rosen 2008-11-17 08:03:18 EST
Created attachment 323760 [details]
rpmfusion  free
Comment 13 Bug Zapper 2008-11-26 00:26:26 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 14 Tim Lauridsen 2009-01-06 05:17:12 EST
this should be fixed in 2.0.5

Note You need to log in before you can comment on or make changes to this bug.