Bug 471735 - netinstall CD gets a woops and an instruction dump, can't proceed.
netinstall CD gets a woops and an instruction dump, can't proceed.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-15 06:18 EST by Joel Rees
Modified: 2009-04-15 16:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-15 16:52:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joel Rees 2008-11-15 06:18:05 EST
Description of problem:
The netinstall CD boots to shortly past the point where the penguin is painted in the upper left-hand corner, and then it gives a woops, debugging stuff scrolls past too fast for me to catch what happened, and then it hits another oops and gives up. 

Can't install, but can reboot with the 4-finger salute (control-option-fn-delete on an iBook).


Version-Release number of selected component (if applicable):
Fedora 10 preview.

How reproducible:
Gets the same results on a G3 clamshell iBook with 576M of RAM and on a G4 white iBook with 768M RAM. The SHA1 signature did check, and Apple's disk utility reported no failure, so I didn't try burning the CD again.


Steps to Reproduce:
1. Download the netinstall image for the preview.
2. Burn the CD.
3. Insert the CD in the iBook.
4. Boot and hold down the C at the chime.
5. Release the C key when the screen flashes.
6. Watch the debug messages and the woops on the screen.
  
Actual results:
Fails to boot the netinstall disk


Expected results:
Wanted to boot the netinstall disk so I could check another bug.

Additional info:
If there is a way to catch the debug printfs, I'll give that a try. Here's what is on the screen when it stops, copied by hand:

--------------------------
iscsi: registered transport (tcp)
detecting hardware...
waiting for hardware to initialize... 
Oops: Exception in kernel mode, sig: 4 [#5]
PowerMac
Modules linked in: iscsi_tcp libiscsi scsi_transport_iscsi ext2 ext4 jbd2 crc16 squashfs pcspkr nfs lockd nfs_acl sunrpc vfat fat cramfs
NIP: c0300000 LR: c03001c4 CTR: c014b824
REGS: e0f77da0 TRAP: 0700   Tainted: G      D     (2.6.27.4-68.fc10.ppc)
MSR: 00089032 <EE,ME,IR,DR>  CR: 24242482  XER: 20000000
TASK = e0f24ce0[509] 'loader' THREAD: e0f76000
GPR00: c03001c4 e0f77e50 e0f24ce0 fffffffe c1893d40 00000000 00000000 00000000
GPR08: 00009032 c0590000 00004000 c0637000 24242482 1004cb38 0fd39b54 0fd3b2fc
GPR16: 00000000 0fd3b2fc 0fd3de10 0fd39b54 00000001 bfdc3a00 0fd5c354 10044b38
GPR24: bfdc3628 10050660 bfdc348e 10050660 e0f77e60 bfdc348e 00000021 e34e2480
NIP [c0300000] sys_connect+0xb0/0xbc
LR [c03001c4] sys_socketcall+0x104/0x258
Call Trace:
[e0f77e50] [c02fffdc] sys_connect+0x8c/0xbc (unreliable)
[e0f77f00] [c03001c4] sys_socketcall+0x104/0x258
[e0f77f40] [c0013db0] ret_from_syscall+0x0/0x38
--- Exception: c01 at 0xfa5ee70
    LR = 0xfd36b5c
Instruction dump:
80cb0018 7d2903a6 4e800421 90610008 8001000c 807f0014 2f800000 41be0008
4bdc16f9 800100b4 80610008 7c0803a6 <00001010> 00000008 00001013 0000000f
---[ end trace ae114bd6a442896f ]---
install exited abnormally [0/0] -- received signal 4
disabling swap...
unmounting filesystems...
          /proc done
          /dev/pts done
          /sys done
sending termination signals...done
sending kill signals...done
you may safely reboot your system
------------------------------

Whew. I think I got that all proofed okay.
Comment 1 Justin Gibson 2008-11-16 16:10:10 EST
Would like to add that I am experiencing the same issue from the Fedora 10 Preview PPC DVD install disk.

Am experiencing it on a G4 powerbook with 1.25GB of memory.
Comment 2 Bug Zapper 2008-11-26 00:26:46 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Joel Rees 2009-01-30 23:53:58 EST
Finally got a chance to check this on the F10 release. 

The netinstall CD boots just fine to the install phase, as it should. Haven't tried an install yet for various reasons, but it appears that the release CD does not have this problem of getting the woops.

One point, I downloaded and burned the preview image under Mac OS X 10.3 (fully updated), but downloaded and burned the release image on the same hardware under Fedora 9. Since the SHA1 checksums were okay both times, the download process is probably no issue, but there is a possibility that Mac OS C X 10.3 botched the burn. I'll try burning the release CD under the Mac OS to see what happens when I have a moment.

Note You need to log in before you can comment on or make changes to this bug.