Bug 471765 - kdesu called from "System Settings" returns "Incorrect password, please try again."
kdesu called from "System Settings" returns "Incorrect password, please try a...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kdebase-runtime (Show other bugs)
11
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-15 20:25 EST by Elgar Pichler
Modified: 2009-07-23 13:54 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-23 13:54:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elgar Pichler 2008-11-15 20:25:04 EST
Description of problem:
Calling kdesu via any System Settings that require root privileges, e.g., 
  System Settings->Advanced->Login Manager
triggers
  /usr/libexec/kde4/kdesu -i preferences-system-network-share-windows \
    "-c /usr/bin/kcmshell4 kdm --lang en_US"
which results in an
  Incorrect password, please try again.
error, although the correct password was entered in the kdesu prompt.

Version-Release number of selected component (if applicable):
System: Fedora 9
RPM: kdebase-runtime-4.1.2-5.fc9.i386

How reproducible:
always

Steps to Reproduce:
see description of problem above
  
Actual results:
see above

Expected results:
The same call to kdesu 
  /usr/libexec/kde4/kdesu -i preferences-system-network-share-windows \
    "-c /usr/bin/kcmshell4 kdm --lang en_US"
issued from a konsole works as expected.

Additional info:
/usr/bin/kdesu (from kdebase3-3.5.10-2.fc9.i386) on the same system 
called from command line with
  /usr/bin/kdesu -i preferences-system-network-share-windows \
    "-c /usr/bin/kcmshell4 kdm --lang en_US"
also has some problems (password is accepted, but KDM settings window
never gets displayed).
Comment 1 Kevin Kofler 2008-11-15 20:32:54 EST
Re the additional info: The KDE 3 kdesu is known to have problems with KDE 4 apps. IMHO we should kill it from kdebase3 and symlink /usr/libexec/kde4/kdesu to /usr/bin/kdesu instead.

But the original error is strange. Any SELinux AVC denials?
Comment 2 Elgar Pichler 2008-11-16 21:35:23 EST
SELinux "System Default Enforcing Mode" is disabled on my system. So I assume the kdesu problem I described is independent of that.
Comment 3 Rex Dieter 2008-11-17 08:50:25 EST
I cannot reproduce, unfortunately.

rpm -q kdelibs kdebase-workspace
please.

Perhaps a wierd variant of bug #457638 ?
Comment 4 Elgar Pichler 2008-11-18 10:25:25 EST
Saw in comments to bug #457638 that other KDE packages might be of interest so I'm listing all KDE related packages that are installed on my system:
 
> rpm -qa | grep -i kde | sort
kde-filesystem-4-19.fc9.noarch
kde-settings-4.0-25.fc9.noarch
kde-settings-kdm-4.0-25.fc9.noarch
kde-settings-pulseaudio-4.0-25.fc9.noarch
kdeaccessibility-4.1.2-2.fc9.i386
kdeadmin-4.1.2-3.fc9.i386
kdeartwork-4.1.2-2.fc9.i386
kdeartwork-extras-4.1.2-2.fc9.i386
kdeartwork-icons-4.1.2-2.fc9.i386
kdeartwork-kxs-4.1.2-2.fc9.i386
kdebase-4.1.2-5.fc9.i386
kdebase-libs-4.1.2-5.fc9.i386
kdebase-runtime-4.1.2-5.fc9.i386
kdebase-runtime-libs-4.1.2-5.fc9.i386
kdebase-workspace-4.1.2-10.fc9.i386
kdebase-workspace-libs-4.1.2-10.fc9.i386
kdebase3-3.5.10-2.fc9.i386
kdebase3-libs-3.5.10-2.fc9.i386
kdebase3-pim-ioslaves-3.5.10-2.fc9.i386
kdebindings-4.1.2-2.fc9.i386
kdebluetooth-0.2-3.fc9.i386
kdeedu-4.1.2-2.fc9.i386
kdeedu-kstars-4.1.2-2.fc9.i386
kdeedu-libs-4.1.2-2.fc9.i386
kdeedu-math-4.1.2-2.fc9.i386
kdegames-4.1.2-2.fc9.i386
kdegames-libs-4.1.2-2.fc9.i386
kdegraphics-4.1.2-2.fc9.1.i386
kdegraphics-libs-4.1.2-2.fc9.1.i386
kdelibs-4.1.2-5.fc9.i386
kdelibs-common-4.1.2-5.fc9.i386
kdelibs3-3.5.10-1.fc9.i386
kdemultimedia-4.1.2-2.fc9.i386
kdemultimedia-libs-4.1.2-2.fc9.i386
kdenetwork-4.1.2-3.fc9.i386
kdenetwork-libs-4.1.2-3.fc9.i386
kdepim-3.5.10-2.fc9.i386
kdepim-libs-3.5.10-2.fc9.i386
kdepimlibs-4.1.2-2.fc9.i386
kdeplasma-addons-4.1.2-2.fc9.i386
kdesdk-4.1.2-3.fc9.i386
kdesdk-libs-4.1.2-3.fc9.i386
kdesdk-utils-4.1.2-3.fc9.i386
kdesvn-1.2.1-1.fc9.i386
kdeutils-4.1.2-3.fc9.i386
kdewebdev-3.5.10-1.fc9.i386
kdewebdev-libs-3.5.10-1.fc9.i386
Comment 5 Ngo Than 2008-11-25 09:10:41 EST
it looks like the same bug #457638. Could you please try KDE 4.1.3 from update-testing?
Comment 6 Elgar Pichler 2008-11-29 13:50:29 EST
As suggested I updated to KDE 4.1.3:
The problem as originally described persists.

Then I upgraded my system to F10. Now my installed KDE RPMS are at version  4.1.3-1.fc10:
Still no luck.

Additional info:
I tried the following:
1. Trigger kdesu via System Settings that require root privileges, as in
     System Settings->Advanced->Login Manager
   That fails with original error
     Incorrect password, please try again.
2. Then I called kdesu from a command line, as in
     /usr/libexec/kde4/kdesu -i preferences-system-login \
       -c "/usr/bin/kcmshell4 kdm --lang en_US"
   entered my password, checked 'Remember password', and got the KDM settings
   window. So that works!
3. Then I closed the KDM settings window and checked if the password was
   remembered. I tried calling up the KDM settings window again with
     System Settings->Advanced->Login Manager
   as well as with
     /usr/libexec/kde4/kdesu -i preferences-system-login \
       -c "/usr/bin/kcmshell4 kdm --lang en_US"
   In both cases I am no longer prompted for a password by kdesu - okay; but
   the KDM settings window never materializes - why?!
4. Then calling
     System Settings->Advanced->Samba
   again throws up the kdesu password prompt with the original problem - why?
All not quite what I expected. I would have expected/hoped that
- kdesu accepts the password even if triggered from System Settings
- I could call up '... kdesu ... -c "/usr/bin/kcmshell4 kdm ...' repeatedly,
  with the password being rememember as requested
- the password would be remembered for all kdesu calls (at least for a certain
  time frame).

Hope that gives any further clues. Cheers,
e2.
Comment 7 Steven M. Parrish 2009-02-06 11:44:33 EST
Is this still an issue with 4.1.4?
Comment 8 Elgar Pichler 2009-02-20 11:46:39 EST
Yup, sorry to say that the problem described above has been an issue with KDE 4.1.x and has still not been resolved for me for KDE 4.2.0.
Cheers,
e2.
Comment 9 Steven M. Parrish 2009-06-07 19:35:09 EDT
Since this is still an issue going to rebase this to F11.

-- 
Steven M. Parrish - KDE Triage Master
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Steven M. Parrish 2009-06-23 10:31:23 EDT
Ping? Kevin's idea in <a href="https://bugzilla.redhat.com/show_bug.cgi?id=471765#c1">comment #1</a> sounds like a good one.

-- 
Steven M. Parrish - KDE Triage Master
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Kevin Kofler 2009-06-23 10:36:08 EDT
That has been implemented a while ago, /usr/bin/kdesu is now a symlink to /usr/libexec/kde4/kdesu. But this doesn't fix the problem this bug is really about, just the "Additional info" part.
Comment 12 Steven M. Parrish 2009-07-21 12:00:43 EDT
So what do we want to do with this?  

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 Rex Dieter 2009-07-21 14:23:53 EDT
Imo, until we can find the root cause (and preferably be able to reproduce it), there's not much we can do.
Comment 14 Ngo Than 2009-07-23 06:17:05 EDT
i cannot reproduce it even with selinux enable (with current kde-4.2.4)
Comment 15 Steven M. Parrish 2009-07-23 13:54:07 EDT
Since this cannot be reproduced at this time going to close this as WORKSFORME.  Please feel free to reopen if the problem returns and you have additional data for us to consider.

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.