This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 471830 - ipa_webgui won't start if python-cherrypy is installed
ipa_webgui won't start if python-cherrypy is installed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ipa (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rob Crittenden
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-16 21:46 EST by Toshio Ernie Kuratomi
Modified: 2009-06-23 18:23 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-23 18:23:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the patch (364 bytes, patch)
2008-11-17 10:28 EST, Toshio Ernie Kuratomi
no flags Details | Diff

  None (edit)
Description Toshio Ernie Kuratomi 2008-11-16 21:46:46 EST
Description of problem:

If python-cherrypy (3.x) is installed, ipa_webgui won't start.  This is due to setuptools not being able to find the python-cherrypy2 package in this case.

In order to reproduce and test this, do:

yum install -y python-cherrypy ipa-server

/usr/sbin/ipa_webgui -f

failed to start web gui: (CherryPy 3.0.3 (/usr/lib/python2.5/site-packages), Requirement.parse('CherryPy>=2.3.0,<3.0.0alpha'))
2008-11-16 18:31:35,463 root ERROR failed to start web gui: (CherryPy 3.0.3 (/usr/lib/python2.5/site-packages), Requirement.parse('CherryPy>=2.3.0,<3.0.0alpha'))
  File "/usr/sbin/ipa_webgui", line 196, in <module>
    main()

  File "/usr/sbin/ipa_webgui", line 157, in main
    pkg_resources.require("TurboGears")

  File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 626, in require
    needed = self.resolve(parse_requirements(requirements))

  File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 528, in resolve
    raise VersionConflict(dist,req) # XXX put more info here


The attached one line patch will make this work by having the ipa_webgui script say it requires turbogears before any imports are performed.
Comment 1 Simo Sorce 2008-11-17 08:32:38 EST
I see no patch attached.
Comment 2 Toshio Ernie Kuratomi 2008-11-17 10:28:32 EST
Created attachment 323774 [details]
the patch

Sorry.  Don't know if it was user error or bugzilla glitch.  here's the patch.
Comment 3 Brennan Ashton 2008-11-19 18:35:54 EST
This bug has been triaged
Comment 4 Bug Zapper 2008-11-26 00:30:06 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Toshio Ernie Kuratomi 2009-06-23 18:23:25 EDT
Fixed in bug #505686

Note You need to log in before you can comment on or make changes to this bug.