Bug 471834 - The doc has an wrong explanation about rhnpush's behavior
The doc has an wrong explanation about rhnpush's behavior
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Docs Channel Management Guide (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: John Ha
Michael Mráka
: Documentation
Depends On:
Blocks: 456984
  Show dependency treegraph
 
Reported: 2008-11-16 23:02 EST by Satoru SATOH
Modified: 2014-08-04 18:18 EDT (History)
4 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:45:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Satoru SATOH 2008-11-16 23:02:52 EST
Description of problem:

Channel Management Guide (Both Satellite Edition 5.2.0 and 5.1.0) says

  -----------------------------------------------------------------------------------
  6.2.1. Configuring the RHN Push Application
  
  When RHN Push is installed, a central configuration file is installed in
  /etc/sysconfig/rhn/rhnpushrc... In addition, the application creates
  ~/.rhnpushrc and ./.rhnpushrc upon its initial use.
  -----------------------------------------------------------------------------------

but it does not look true. As far as I tested, rhnpush does not create configuration 
files upon its initial use.


Version-Release number of selected component (if applicable):

Red Hat Network Satellite 5.2, Channel Management Guide,
Red Hat Network Satellite, Edition 5.2

As far as I confirmed, both rhnpush-5.2.0-1 (latest) and git HEAD in spacewalk don't
write configuration automatically at all.


How reproducible: always


Steps to Reproduce:
1. install rhnpush and run it
2.
3.
  
Actual results: rhnpush does not create configuration files on initial startup.


Expected results: rhnpush creates configurations as the doc said.


Additional info:

It seems that both rhnpush in Satellite and Spacewalk have a method to write configuration 
files but it never called.

  e.g. ConfManager._write_config_file() in 
       spacewalk/client/tools/rhnpush/rhnpush_confmanager.py

But I don't think it's a bug of rhnpush nor expected behavior.  
So, I file it as a documentation error.
Comment 1 Brandon Perkins 2008-11-20 13:02:24 EST
Looks like we should just remove that sentence.
Comment 4 Michael Mráka 2009-04-22 04:56:27 EDT
Verified.
Comment 6 Brandon Perkins 2009-09-10 16:45:07 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.