Bug 471837 - [QLogic/NetApp 5.4 bug] QLogic iscli fails to detect iSCSI HBA.
[QLogic/NetApp 5.4 bug] QLogic iscli fails to detect iSCSI HBA.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
All Linux
medium Severity medium
: beta
: 5.4
Assigned To: Marcus Barrow
Red Hat Kernel QE team
: OtherQA
Depends On:
Blocks: 460170 461680
  Show dependency treegraph
 
Reported: 2008-11-16 23:39 EST by nandkumar mane
Modified: 2009-06-20 04:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-24 21:46:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nandkumar mane 2008-11-16 23:39:27 EST
Description of problem:
On RHEL5.3 Snapshot1 machine, I am using inbox qlogic driver and iscli, to configure HBA.  During configuration, I observed that iscli is failing to detect iSCSI HBA. 'HBA Level Info & Operations'option is erroring out with message "No HBA Found".

lspci output shows that qlogic HBA has been detected.
05:01.0 Ethernet controller: QLogic Corp. ISP4022-based Ethernet NIC (rev 03)
05:01.1 Network controller: QLogic Corp. ISP4022-based iSCSI TOE HBA (rev 03)
05:01.2 Ethernet controller: QLogic Corp. ISP4022-based Ethernet NIC (rev 03)
05:01.3 Network controller: QLogic Corp. ISP4022-based iSCSI TOE HBA (rev 03)

lsmod shows that qlogic driver is loaded.
lsmod | grep ql
qla3xxx                69961  0
qla4xxx                95585  0
scsi_transport_iscsi    67025  1 qla4xxx
scsi_mod              196569  9 scsi_dh,sg,libata,qla4xxx,scsi_transport_iscsi,mptspi,mptscsih,scsi_transport_spi,sd_mod


Version-Release number of selected component (if applicable):
OS : RHEL5U3
iSCSI HBA : QLA4052C
module : qla4xxx  version 5.01.00.00.05.03-k8
SANsurfer iSCSI HBA CLI
Program Version : 1.2.00.07
iSDMAPI : 00.05.05.04 QLSDM.DLL 06 IOCTL
Copyright 1999-2007 QLogic Corp.


How reproducible:
Very reproducible

Steps to Reproduce:
1.Install RHEL5U3.
2.Download iscli from qlogic site.
3.Try to configure HBA using iscli.
  
Actual results:
You will find "No HBA Found" after selecting "HBA Level Info & Operations" option. 

Expected results:
HBA information should be shown.

Additional info:
I found same problem in RHEL5U2, but after SANsurfer GUI and Agent installtion I didn't see this issue.
In case of RHEL5U3 even after SANsurfer installation, I am facing same issue.
I think qisioctl module is playing some role here.
Comment 1 nandkumar mane 2009-02-12 10:56:22 EST
The problem is with iscli, shifted with RHEL5.3. It fails to install qisioctl module showing following error.
# ./iscli.dkms.install.sh install force
installing ./iscli-1.2.00-15_linux_i386.rpm
installing ./iscli-1.2.00-15_linux_i386.rpm
Executing: rpm -ivh --force ./iscli-1.2.00-15_linux_i386.rpm
Preparing...                ########################################### [100%]
   1:iscli                  ########################################### [100%]
Installation completed successfully.
Executing: tar -zxf ./qisioctl.tar.gz
Attempting to install qsisioctl (./qisioctl-dkms-install.sh)
Current dir: /opt/QLogic_Corporation/SANsurferiCLI/qisioctl
./qisioctl-dkms-install.sh -i 2>&1  > ./qisioctl.log
DKMS and QISIOCTL module install status=0
grep-relult=""
Preparing...                ##################################################
iSCSI IOCTL module not required for this vesion of qla4xxx module
Skipping installation of iSCSI IOCTL module...


QLogic should change qisioctl script (qisioctl-dkms-install.sh) so that script 
will install ioctl module(v2.01.00b9) even if there is qla4xxx module(5.01.00.01.05.03-k9). R5U3 doesn't ship with qisioct module.

Workarround to this problem is to install qisioctl rpm manually, to get module installed and loaded.
Comment 2 RHEL Product and Program Management 2009-02-16 10:33:29 EST
Updating PM score.
Comment 3 nandkumar mane 2009-02-16 13:01:19 EST
We are talking to QLogic about this issue. Next iscli release will have this problem resolved.
Comment 4 nandkumar mane 2009-03-20 03:36:33 EDT
New iscli.dkms.install.sh shipped with iscli package (1.2.00.21), installs qisioctl module properly on RHEL5U3, which resolves the iscli and HBA communication problem.
Veried on RHEL5U3. Thanks for the fix.

Note You need to log in before you can comment on or make changes to this bug.