Bug 471855 - Include ON_DEV bugs in My Front Page
Include ON_DEV bugs in My Front Page
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Query/Bug List (Show other bugs)
3.2
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: Noura El hawary
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-17 02:40 EST by Debarshi Ray
Modified: 2013-06-24 00:07 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-24 01:50:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
v1 of adding ON_DEV to frontpage assigned_to bugs (1.60 KB, patch)
2008-11-19 19:50 EST, Noura El hawary
dkl: review+
Details | Diff

  None (edit)
Description Debarshi Ray 2008-11-17 02:40:20 EST
Description of problem:
The "My Front Page" does not list bugs whose status is ON_DEV. Since Fedora's bug status workflow [1] involves the ON_DEV state when someone starts working on a fix, it would be good if such bugs are suitably displayed.

Although the "My Bugs" page does include ON_DEV bugs, the page is just a flat list and not structured as "My Front Page". It would be good to have such kinds of bugs in the latter page itself.

[1] https://fedoraproject.org/wiki/BugZappers/BugStatusWorkFlow

Steps to Reproduce:
1. Change the status of a bug to ON_DEV.
2. Click on "My Front Page" and the bug is not listed.
  
Expected results:
ON_DEV bugs should be suitably listed on "My Front Page".

Additional info:
The inclusion of the ON_DEV status in the bug status workflow was discussed in this thread: https://www.redhat.com/archives/fedora-devel-list/2008-November/msg00283.html
Comment 1 Noura El hawary 2008-11-19 19:46:01 EST
(In reply to comment #0)
> Description of problem:
> The "My Front Page" does not list bugs whose status is ON_DEV. Since Fedora's
> bug status workflow [1] involves the ON_DEV state when someone starts working
> on a fix, it would be good if such bugs are suitably displayed.
> 

Hey Debrashi, actually My front Page , include ON_DEV status in the case if you were the bug reporter under "Issues in Progress Reported by You", and in the case if you were in the cclist of the bug under "Issues You are CC'd on", Now in the case if you were the assignee of the bug that status is not included any where, so i am attaching a patch to include that.

> Although the "My Bugs" page does include ON_DEV bugs, the page is just a flat
> list and not structured as "My Front Page". It would be good to have such kinds
> of bugs in the latter page itself.

Basically "My Bugs" is just a bugzilla saved query , which means it produces a normal query search result, I don't think we would do any changes to it, if you would like to see it change i would recommend you file a bug for that upstream.

Noura

> 
> [1] https://fedoraproject.org/wiki/BugZappers/BugStatusWorkFlow
> 
> Steps to Reproduce:
> 1. Change the status of a bug to ON_DEV.
> 2. Click on "My Front Page" and the bug is not listed.
> 
> Expected results:
> ON_DEV bugs should be suitably listed on "My Front Page".
> 
> Additional info:
> The inclusion of the ON_DEV status in the bug status workflow was discussed in
> this thread:
> https://www.redhat.com/archives/fedora-devel-list/2008-November/msg00283.html
Comment 2 Noura El hawary 2008-11-19 19:50:49 EST
Created attachment 324124 [details]
v1 of adding ON_DEV to frontpage assigned_to bugs

Hey Dave,

I have added ON_DEV plus all the other open bug status to the section of Open bugs assigned to you, Do you think this would be the right solution so we don't make the front page more crowded, or shall i just add ON_DEV and leave the other extra ones, or shall i just create a new section called "ON_DEV bugs assigned to you".


Noura
Comment 3 David Lawrence 2008-11-23 21:44:19 EST
Comment on attachment 324124 [details]
v1 of adding ON_DEV to frontpage assigned_to bugs

Looks good Noura.
Comment 4 Noura El hawary 2008-11-24 01:50:41 EST
Thanks for the review Dave, committed to cvs.

Noura

Note You need to log in before you can comment on or make changes to this bug.