Bug 472009 - PyXML package does not include egg info
PyXML package does not include egg info
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: PyXML (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Roman Rakus
Lukas Zachar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-18 03:17 EST by Arnaud Gomes-do-Vale
Modified: 2014-01-12 19:08 EST (History)
7 users (show)

See Also:
Fixed In Version: PyXML-0.8.4-6.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-21 02:20:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
no PyXML egg-info file patch for python-ZSI (586 bytes, patch)
2009-02-25 03:48 EST, Douglas Kosovic
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 430344 None None None Never

  None (edit)
Description Arnaud Gomes-do-Vale 2008-11-18 03:17:12 EST
Description of problem:

The directory /usr/lib/python2.4/site-packages/PyXML-0.8.4-py2.4.egg-info and its contents are missing from the PyXML package. This prevents at least some parts of the ZSI python module from working correctly.

Version-Release number of selected component (if applicable):

PyXML-0.8.4-4

How reproducible:

Always

Steps to Reproduce:
1. install PyXML
2. look for /usr/lib/python2.4/site-packages/PyXML-0.8.4-py2.4.egg-info
  
Actual results:

No /usr/lib/python2.4/site-packages/PyXML-0.8.4-py2.4.egg-info.

Expected results:

/usr/lib/python2.4/site-packages/PyXML-0.8.4-py2.4.egg-info should exist.

Additional info:

This has been fixed in Fedora, see bug 430344.
Comment 1 Douglas Kosovic 2009-02-25 03:48:43 EST
Created attachment 333142 [details]
no PyXML egg-info file patch for python-ZSI

To avoid /usr/bin/wsdl2py from the python-ZSI package breaking at runtime due to the missing egg info file in PyXML, I rebuilt the Fedora python-ZSI SRPM with the attached patch. It removes the problematic PyXML version check which requires the PyXML egg info file.
Comment 4 Roman Rakus 2010-04-07 07:33:07 EDT
Cannot be fastrack because of bug 531854
Comment 7 RHEL Product and Program Management 2010-08-09 15:26:34 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 12 errata-xmlrpc 2011-11-21 02:20:17 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1460.html

Note You need to log in before you can comment on or make changes to this bug.