Bug 472010 - UIlocale and contentLocal options do nothing
UIlocale and contentLocal options do nothing
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: thunderbird (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jan Horak
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-18 03:24 EST by Yolkfull Chow
Modified: 2009-04-15 04:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-15 04:20:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of character "Localhost" that has not localized to korean (160.77 KB, image/png)
2008-11-18 03:27 EST, Yolkfull Chow
no flags Details

  None (edit)
Description Yolkfull Chow 2008-11-18 03:24:49 EST
Description of problem:
Launch thunderbird with zh-TW locale the first time, and finish setting up an account. And then quit thunderbird, launch thunderbird with UIlocale, i.e. "#thunderbird -UIlocale ko" , you can see the zh-TW font is still there and has not localized to Korean.

Version-Release number of selected component (if applicable):
thunderbird-2.0.0.18-1.el5

How reproducible:
Everytime

Steps to Reproduce:
1. create a new profile and launch thunderbird with the new profile(#thunderbird -createprofile test_cjk; #thunderbird -P test_cjk
2. finish setting up a new account
3. quit thunderbird and launch it with UIlocale ko, #thunderbird -UIlocale ko(or ja-JP,or zh)
  
Actual results:
"Localhost" should be localized to corresponding font when launch thunderbird with UIlocale .

Expected results:
"Localhost" cannot be localized and can only show the font from the first time launch.

Additional info:
Comment 1 Yolkfull Chow 2008-11-18 03:27:44 EST
Created attachment 323860 [details]
Screenshot of character "Localhost" that has not localized to korean
Comment 3 Matěj Cepl 2008-11-21 18:36:00 EST
Maybe instead of fonts, we should focus on the fact that neither -contentLocale nor -UILocale do anything at all. Both in RHEL 5 as well as in Rawhide. Firefox at least doesn't advertise -contentLocale, but thunderbird does and only when being started it shows a warning "unrecognized command line flag -contentLocale".

The only thing which seems to affect firefox/thunderbird is the locale -- so if you want to run Chinese firefox in the session with ja_JP locale, you have to run

LANG=zh_CN firefox

otherwise you will have Japanese.
Comment 4 Jan Horak 2009-04-02 04:36:58 EDT
Actually -UILocale is working well (tested on reported version). For example it just does not accept '-UILocale ja_JP' format but only '-UILocale ja'. 

The described problem is that the title for 'Local Folders' is set during account creation according to used locale. So if you later decide to use different locale the title of 'Local folders' stay fixed to value determined during account creation.

The name of 'Local folders' is located in user preferences and can be changed any time in account settings. It seems to be desired feature to allow rename 'Local folder' by user and not to change it according to actual locale.
Comment 5 Jan Horak 2009-04-15 04:20:05 EDT
The -UILocale is working and -contentLocale will be removed in next release. This bug is only about untranslated 'Local folders' when running using different locale. It seems to be wanted behaviour because 'Local folders' name can be changed by user any time. Therefore closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.