Bug 472091 - kernel panic No init found
kernel panic No init found
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kvm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-18 12:52 EST by eric magaoay
Modified: 2013-01-09 23:55 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-20 16:47:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
kernel panic output (19.79 KB, image/png)
2008-11-18 12:52 EST, eric magaoay
no flags Details
debug out output (12.98 KB, application/octet-stream)
2008-11-18 17:18 EST, eric magaoay
no flags Details
kickstart file (315 bytes, text/plain)
2008-11-19 10:26 EST, eric magaoay
no flags Details
debug outputs w/ the new simplified commandline (12.95 KB, application/octet-stream)
2008-11-19 10:28 EST, eric magaoay
no flags Details

  None (edit)
Description eric magaoay 2008-11-18 12:52:28 EST
Created attachment 323941 [details]
kernel panic output

Description of problem:
While performing new install, kernel panic when it could not find init.

command executed:
/usr/bin/qemu-kvm -drive file=/a/m/sf/dev/i386/os/images/boot.iso,media=cdrom -drive file=/a/i/fda0  -localtime -usbdevice tablet  -name fda0-17740 -net nic,vlan=7740,macaddr=55:55:55:01:18:40 -net user,vlan=7740,hostname=fda0-17740 -m 512

Version-Release number of selected component (if applicable):
kernel-2.6.27.5-113.fc10.i686

How reproducible:
persistent

Additional info:
attached copy of output
Comment 1 Glauber Costa 2008-11-18 14:02:25 EST
Eric,

Can you add a -serial to your command line, edit your grub (or whatever) to get console=ttyS0 as well, and send that file to us? 

A recent enough kernel got the scheduler running earlier (probably your case, but not sure), so it is quite possible that any relevant messages are far beyond what you can see in the screen.
Comment 2 eric magaoay 2008-11-18 17:18:56 EST
Created attachment 323974 [details]
debug out output

New complete command executed:

/usr/bin/qemu-kvm -kernel /a/m/sf/dev/i386/os/isolinux/vmlinuz -initrd /a/m/sf/dev/i386/os/isolinux/initrd.img -append "ksdevice=52:54:00:01:18:40 ks=http://192.168.5.101/a/ks/fda0-17740 console=ttyS0,115200" -drive file=/a/i/fda0,boot=on  -serial file:/a/q/z.debug  -name fda0-17740 -net nic,vlan=7740,macaddr=52:54:00:01:18:40 -net tap,vlan=7740,ifname=fda0-17740,script=/a/q/tap.sh -m 512   

attached is the complete debug output
Comment 3 Glauber Costa 2008-11-19 07:25:28 EST
I don't know exactly what does "ks" are, but you don't seem to be mounting any root device here.
Comment 4 eric magaoay 2008-11-19 10:26:36 EST
Created attachment 324053 [details]
kickstart file

ks is the kickstart file (attached). I normally use kickstart file for new install, even under KVM, and never had problem with it. Here is a simplified commandline without the extraneous options for this test:

/usr/bin/qemu-kvm -kernel /a/m/sf/dev/i386/os/isolinux/vmlinuz -initrd /a/m/sf/dev/i386/os/isolinux/initrd.img -append "console=ttyS0,115200" -drive file=/a/i/fda0,boot=on  -serial file:/a/q/z/z.debug -m 512
Comment 5 eric magaoay 2008-11-19 10:28:34 EST
Created attachment 324054 [details]
debug outputs w/ the new simplified commandline
Comment 6 eric magaoay 2008-11-19 15:07:52 EST
I just want to add that under x86_64 I was able to complete installation.
Comment 7 Mike Putnam 2008-11-19 23:14:49 EST
I've also experienced this same bug/symptom on a physical box (as opposed to eric's QEMU attempt) using the 11/18 closest-mirror/pub/fedora/development/i386/os/images/boot.iso and taking the default options.
Comment 8 Mike Putnam 2008-11-19 23:44:43 EST
Propose moving this bug to kernel Component rather than kvm.
Comment 9 Jesse Keating 2008-11-19 23:49:18 EST
mike, you need to show your full logs.  The trees from the 18th I do believe had a broken anaconda due to glibc changes, so we'd want to get your results from the 19th's tree (today).
Comment 10 Mike Putnam 2008-11-19 23:57:52 EST
Jesse, Apologies.  I had no logs other than the last three lines of panic.

However, since then I've checked my nearest mirror and lo and behold an 11/19 boot.iso appeared.  Bug fixed on my physical box.  (Unless of course this really is a kvm bug.)
Comment 11 Jesse Keating 2008-11-20 00:05:15 EST
What is the kvm version and kernel version of the host?  I am not able to reproduce this with kvm-74-5.fc10.x86_64 and kernel-2.6.27.5-101.fc10.x86_64 using the kernel and initrd from 20081119.
Comment 12 eric magaoay 2008-11-20 15:16:48 EST
The latest build tree(11/20/08) I just download this morning resolved the problem.

kvm-74-5.fc10.x86_64.rpm
qemu-0.9.1-10.fc10.x86_64.rpm
kernel-2.6.27.5-117.fc10.x86_64.rpm
Comment 13 Jesse Keating 2008-11-20 16:47:37 EST
Ok, this wasn't a bug in kvm, it was a compose tool issue.

Note You need to log in before you can comment on or make changes to this bug.