Bug 472102 - yumex does not start
yumex does not start
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
9
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-18 14:15 EST by Farzad Ghanei
Modified: 2009-06-16 03:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-06 05:15:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Farzad Ghanei 2008-11-18 14:15:20 EST
Description of problem:
when starting yumex, it will show an error message telling this:
Error Type: <class 'yum.update_md.UpdateNoticeException'> 
Error Value: No id element found 
  File : /usr/share/yumex/yumex.py , line 737, in <module>
    mainApp = YumexApplication() 
  File : /usr/share/yumex/yumex.py , line 446, in __init__
    self.setupYum() 
  File : /usr/share/yumex/yumex.py , line 467, in setupYum
    self.yumbase._setupBase() 
  File : /usr/share/yumex/yumapi.py , line 80, in _setupBase
    self._setupUpdateMetadata() 
  File : /usr/share/yumex/yumapi.py , line 137, in _setupUpdateMetadata
    self.updateMetadata.add(repo) 
  File : /usr/lib/python2.5/site-packages/yum/update_md.py , line 319, in add
    un = UpdateNotice(elem) 
  File : /usr/lib/python2.5/site-packages/yum/update_md.py , line 69, in __init__
    self._parse(elem) 
  File : /usr/lib/python2.5/site-packages/yum/update_md.py , line 146, in _parse
    raise UpdateNoticeException("No id element found") 



Version-Release number of selected component (if applicable):
yumex-2.0.4-1.fc9.noarch

How reproducible:
always

Steps to Reproduce:
1.run the application
2.
3.
  
Actual results:
shows the error message and closes the application

Expected results:
start the yumex application

Additional info:
Comment 1 Bryan L. Gay 2008-12-10 18:57:57 EST
I've tried this with yumex on a fresh install of F10 using the updates repo included in install, same results.

Also, Smart package manager, apt-get, and every other package manager I've tried, including the built-in Add/Remove Software all die a horrible python-related death. I'm running the i386 platform, so this can be marked as affecting both platforms.

Let me know what details other than the above need to be added to this bug. I'm re-installing F10 without the updates repo to see if this is an updates-introduced bug. Will report back with the results.

I also have a F10 installed from rawhide that I'll check to see if this machine has been affected.
Comment 2 Tim Lauridsen 2008-12-11 01:28:12 EST
This is fixed in yumex-2.0.5 currently in updates-testing

yum --enablerepo=updates-testing update yumex

Note You need to log in before you can comment on or make changes to this bug.