Bug 472135 - something wrong in perl configuration
something wrong in perl configuration
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-18 17:08 EST by Andrea Santilli
Modified: 2008-11-19 13:17 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-19 09:47:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
detailed perl configuration (33.42 KB, text/plain)
2008-11-19 02:33 EST, Andrea Santilli
no flags Details

  None (edit)
Description Andrea Santilli 2008-11-18 17:08:05 EST
Description of problem:
the perl package reports a wrong configuration. i noticed this problem while rebuilding an rpm.
perl shows the following the paths, which are wrong:

$ perl -V:sitearchexp
sitearchexp='/usr/local/lib/perl5/site_perl/5.10.0/i386-linux-thread-multi';

$ perl -V:sitearch
sitearch='/usr/local/lib/perl5/site_perl/5.10.0/i386-linux-thread-multi';

$ perl -V:sitelibexp
sitelibexp='/usr/local/lib/perl5/site_perl/5.10.0';

$ perl -V:sitelib
sitelib='/usr/local/lib/perl5/site_perl/5.10.0';

but the prefix variable is right:

$ perl -V:prefix
prefix='/usr';

Version-Release number of selected component (if applicable):
perl-5.10.0-38.fc9.i386
Comment 1 Andrea Santilli 2008-11-19 02:33:12 EST
Created attachment 324008 [details]
detailed perl configuration

here attached is the output of perl -V:.*
Comment 2 Ralf Corsepius 2008-11-19 05:53:12 EST
(In reply to comment #0)
> Description of problem:
> the perl package reports a wrong configuration. i noticed this problem while
> rebuilding an rpm.
> perl shows the following the paths, which are wrong:
What makes you think these are wrong?
Comment 3 Marcela Mašláňová 2008-11-19 06:48:39 EST
I suppose you run your local build perl and then is the path ok. It should be in /usr/local.
Comment 4 Ralf Corsepius 2008-11-19 09:13:54 EST
(In reply to comment #3)
> I suppose you run your local build perl and then is the path ok.
I guess, no, the OP did not build a local perl, because the paths in Fedora's perl point to /usr/local

> It should be in /usr/local.
IIRC, since a change from Stephan K., are supposed to point to /usr/local, to reflect the fact Fedora doesn't ship any site* packages.
Comment 5 Stepan Kasal 2008-11-19 09:47:13 EST
(In reply to comment #4)
> IIRC, since a change from Stephan K., are supposed to point to /usr/local, to
> reflect the fact Fedora doesn't ship any site* packages.

... and that modules istalled directly from CPAN often go to sitelib, so it is appropriate to have sitelib under /usr/local, with other site-specific software.

To sum up, the change was intentional.
Comment 6 Andrea Santilli 2008-11-19 13:17:36 EST
Ok, I thought that making it point to /usr/local was wrong, since some times ago it used to point to /usr.

sorry, my mistake and thank you very much for replying quickly :)

Note You need to log in before you can comment on or make changes to this bug.