Bug 472138 - Missing svm flag in cpuinfo for 32-bit RHEL4
Missing svm flag in cpuinfo for 32-bit RHEL4
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.9
i686 Linux
medium Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-18 17:23 EST by Dave Botsch
Modified: 2011-11-03 13:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-03 13:35:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Botsch 2008-11-18 17:23:51 EST
Description of problem:

On multiple motherboard vendors with virtualization capable Opteron 2216s, 32-bit RHEL4 is not showing the SVM flag in the output of /proc/cpuinfo. If one reboots into 64-bit RHEL4, the svm flag is there.

Version-Release number of selected component (if applicable):


How reproducible:
100% of the time


Steps to Reproduce:
1.Choose a mobo - two I've tried are KFSN4-DRE and Tyan S2927
2.Boot 32-bit RHEL4
3. cat /proc/cpuinfo or run lshw
  
Actual results:
svm flag is not present under rhel4-32bit


Expected results:
svm flag should be present under rhel4-32bit


Additional info:
As I said, this is only happening w. 32-bit RHEL4. In the case of the Tyan mobo, Tyan has confirmed that other 32-bit linux distros (they did not tell me which one) DO indeed show the svm flag.

cpuid shows the following on both motherboards (regardless of 32-bit or 64-bit rhel4):
  AMD feature flags (0x80000001/ecx):
      LAHF/SAHF supported in 64-bit mode = true
      CMP Legacy                         = true
      SVM: secure virtual machine        = true
      AltMovCr8                          = true


   SVM Secure Virtual Machine (0x8000000a/eax):
      SvmRev: SVM revision = 0x1 (1)
   SVM Secure Virtual Machine (0x8000000a/edx):
      LBR virtualization = false

Note You need to log in before you can comment on or make changes to this bug.