Bug 472140 - yum selects slow mirrors
yum selects slow mirrors
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mirrormanager (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Domsch
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-18 17:31 EST by Nikos Charonitakis
Modified: 2014-01-21 18:06 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-28 21:38:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikos Charonitakis 2008-11-18 17:31:27 EST
Description of problem:
I ve done many fresh fedora installations (9 or 10 preview) and performing updates as usual.
Downloading speed is very slow (around 30-50 kb per seconds)
So i  manually edit repos and add (for example) a german server.
Now download speed is 10 times faster or more. 
I have seen many complaints about updates download speed in local Greek forums.
This slowness give the false impression that yum or packagekit is extremely slow (endless downloading filelists or packages). 
This problem maybe related with Greek servers that yum selects. 
Any thoughts or solution about all these?




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 James Antill 2008-11-18 23:27:26 EST
 You could try installing yum-fastestmirror, apart from that it's all data from MirrorManager.
Comment 2 Matt Domsch 2008-11-19 07:55:32 EST
http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/releases/9/Everything/i386/os&country=gr

shows me that there are two mirrors in Greece.  When there are less than three mirrors in your country, MirrorManager adds mirrors from your same continent to the list, and then tries to send you to one of those mirrors with fast bandwidth (mirrors with gigabit speeds are chosen more often than mirrors with only 100Mbits).

What mirrors appear for you when you hit this page (you can do it from a web browser)?  Alternately, what is your IP address?

http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/releases/9/Everything/i386/os

Thanks,
Matt
Comment 3 Nikos Charonitakis 2008-11-19 09:56:57 EST
I get those 2 when i hit your link:
1)http://ftp.ntua.gr/pub/linux/fedora/linux/releases/9/Everything/i386/os
2)http://ftp.cc.uoc.gr/pub/fedora/linux/releases/9/Everything/i386/os

i tried with firefox to download some packages directly from these sites.
1) was ok
2) is downloading about 20-30 kb/second 

2) is a  few kilometers near my home :)

MirrorManager propably selects this one (pressing ctrl-c during yum install shows its address). Is nearby but it is too slow.
 
So the situation here in Greece is:
Many users will have problems if MirrorManager selects ftp.cc.uoc.gr
Can you fix it to select the faster one. One user that installed yum-fastermirror told me that didnt solve this speed problem. Anyway this is an extra headache that will cause some (not needed) confusion to new greek users of fedora.

Nikos
Comment 4 Matt Domsch 2008-11-19 14:25:00 EST
Dimitris, Nikos is reporting that your mirror is exceedingly slow.  Care to investigate?  MirrorManager lists you as capable of serving at 100Mbits/sec, but he is reporting 20-30Kb/sec.

Thanks,
Matt
Comment 5 Nikos Charonitakis 2008-11-25 15:37:22 EST
new problems with this particular mirror

message: permission denied
http://ftp.cc.uoc.gr/pub/fedora/linux/releases/10/Live/i686/F10-i686-Live.iso when you hit download now button from http://fedoraproject.org/get-fedora
Comment 6 Jon Stanley 2008-11-25 17:20:44 EST
Dimitirs,

Can you either run another rsync or manually do the bitflip?  releases/10 is still not readable from your mirror.
Comment 7 Jon Stanley 2008-11-25 17:35:47 EST
I've administratively lowered the bandwidth on this mirror to 1. Dmitris, please change it through the MM web interface to whatever value is correct once you've fixed it (i.e. done the bitflip)
Comment 8 Bug Zapper 2008-11-26 00:34:58 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Nikos Charonitakis 2008-11-27 09:32:02 EST
 A good idea in my opinion is to remove this server immediately (until problems are resolved).
Speed unfortunately is getting slower <20k and many users will auto redirected to this server.
I think also preupgrade is affected too.
Comment 10 Kapetanakis Giannis 2008-11-27 09:59:36 EST
The server (ftp.cc.uoc.gr) has 100Mbit upload to it's upstream provider.
which is full 24/365.(In reply to comment #4)
> Dimitris, Nikos is reporting that your mirror is exceedingly slow.  Care to
> investigate?  MirrorManager lists you as capable of serving at 100Mbits/sec,
> but he is reporting 20-30Kb/sec.
> 
> Thanks,
> Matt


The server is capabe of serving at 100Mbps and actually it does
at 100Mbps 24/365.

sorry but we cannot serve each user at 100Mbps ...

btw the mirror is not dedicated to fedora.
Actually most requests are for other distributions.

if the server is slow for some users then
yum-fastestmirror should be able to redirect them to another 
faster mirror.

If yum-fastestmirror does not redirect them to another mirror
then it's a yum-fastestmirror's bug and NOT a server problem.

best regards,

Giannis
ftpadm [at] cc.uoc.gr
Comment 11 Counalakis Dimitris 2008-11-27 10:14:48 EST
(In reply to comment #7)
> I've administratively lowered the bandwidth on this mirror to 1. Dmitris,
> please change it through the MM web interface to whatever value is correct once
> you've fixed it (i.e. done the bitflip)


Giannis is right (Comment #10 From  Kapetanakis Giannis).
Yes, on Nov 25th F10 was not available, but on Nov 26 it was. I actually
encouraged some friends around Europe to download from our 
server  -- since many of the fedora mirrors were outdated till then.
They didn't experience any problems/delays.
Enough said :)

plz Jon, change it back to 100 Mbps. The MM interface insists on keeping
1 Mbps (another bug?). I have already tried to change it 4 times(!)

Niko, check your provider's status. For domestic networks HOL reports
ok, Forthnet doesn't.

Take care ...
Dimitris ...
Comment 12 Kapetanakis Giannis 2008-11-28 08:43:24 EST
The server has been modified in order for Greece to have priority 
in traffic, via GeoIP.

Things should be a little bit better now for local users.

Regards,

Giannis
Comment 13 Matt Domsch 2008-11-28 21:38:52 EST
Yes, MM has a "bug" in the caching of data entered via the web forms, whereby you can change a field, hit save, and then it doesn't appear as if the data was saved.  I haven't figured out a way around TG's "all or nothing" caching model yet.  I hear TG2 may be better at this.

Giannis: your server lists as 100 now.

As server has been adjusted, closing.

Thanks,
Matt

Note You need to log in before you can comment on or make changes to this bug.