Bug 472141 - Privoxy no longer updates its logfile
Privoxy no longer updates its logfile
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: privoxy (Show other bugs)
9
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-18 17:32 EST by Frank Cox
Modified: 2008-12-13 00:13 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-13 00:13:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Cox 2008-11-18 17:32:25 EST
Description of problem:
I upgraded a couple of my computers from F8 to F9 the other day and have
discovered that Privoxy no longer updates its logfile.

/etc/privoxy/config contains the following lines, both of which are uncommented.

logdir /var/log/privoxy
logfile logfile

However, as you can see here, the last time the privoxy logfile was updated was
on November 3, when I updated this machine from F8 to F9.

[root@mutt log]# ls -ld privoxy
drwx--x--x 2 privoxy privoxy 4096 2008-03-05 06:43 privoxy
[root@mutt log]# ls -l privoxy
total 1220
-rw-r--r-- 1 privoxy privoxy 585562 2008-11-03 17:45 logfile
-rw-r--r-- 1 privoxy privoxy 165643 2008-10-24 04:02 logfile-20081024.gz
-rw-r--r-- 1 privoxy privoxy 138819 2008-10-27 04:02 logfile-20081027.gz
-rw-r--r-- 1 privoxy privoxy 194770 2008-10-30 04:02 logfile-20081030.gz
-rw-r--r-- 1 privoxy privoxy 137054 2008-11-02 04:02 logfile-20081102.gz

I also put F10-beta/i386 on my Acer Aspire One laptop the other day and it,
too, doesn't create any logfile in /var/log/privoxy.  I got one entry from the
day that I installed it saying that the configuration was incorrect, and nothing
ever since then.

So I now have two computers with F9 and one with F10 and none of them have
privoxy doing any logging.


Version-Release number of selected component (if applicable):
privoxy-3.0.8-2.fc9.x86_64


How reproducible:
every time

Steps to Reproduce:
1.Install privoxy and activate.  
2.Browse the web with Firefox through privoxy.
3.
  
Actual results:
Nothing gets written to /etc/privoxy/logfile

Expected results:
A log should be written showing the sites and images processed by privoxy.

Additional info:

This worked fine with F8 but doesn't work with F9 and F10 so something has changed and broke the logging.
Comment 1 Karsten Hopp 2008-11-19 05:20:09 EST
Have you restarted privoxy in the meantime ?
Are you using selinux, are there any AVC messages in any of the logfiles in /var/log ?
Comment 2 Frank Cox 2008-11-19 10:58:22 EST
I have restarted privoxy several times.

selinux is disabled.  I just double-checked that with system-config-selinux.py and it says "System Default Enforcing Mode: Disabled".

I have three computers that are currently affected by this.  Here are the last few lines of the logfile in the machine that I upgraded from F8 to F9 a few days ago:

Nov 14 15:49:58 Privoxy(4420e950) Request: gulus.usherbrooke.ca/pub/distro/fedora/linux/releases/9/Fedora/x86_64/os/images/pxeboot/initrd.img
Nov 14 15:49:59 Privoxy(4420e950) Request: gulus.usherbrooke.ca/pub/distro/fedora/linux/releases/9/Fedora/x86_64/os/images/pxeboot/initrd.img
Nov 14 15:50:15 Privoxy(4420e950) Request: gulus.usherbrooke.ca/pub/distro/fedora/linux/releases/9/Fedora/x86_64/os/images/stage2.img
Nov 14 15:50:15 Privoxy(4420e950) Request: gulus.usherbrooke.ca/pub/distro/fedora/linux/releases/9/Fedora/x86_64/os/images/stage2.img
Nov 14 15:53:19 Privoxy(7f2e093ff6f0) Info: exiting by signal 15 .. bye

As you can see, the last entries in the logfile are the final downloads using preupgrade when updating that machine from F8 to F9.  Privoxy otherwise seems to be running fine and working fine.  It just doesn't write to its logfile.
Comment 3 Frank Cox 2008-12-13 00:13:37 EST
I finally discovered the reason for this.  The privoxy config file (/etc/privoxy/config) has changed defaults from what it used to be.

Uncommenting this line:

debug      1 # log each request destination (and the crunch reason if Privoxy in
tercepted the request)

causes the logging to work again.

Note You need to log in before you can comment on or make changes to this bug.