Bug 472197 - vfolder "unread mails" regression (fix upstream)
vfolder "unread mails" regression (fix upstream)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
10
All Linux
high Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-19 05:35 EST by Osma Ahvenlampi
Modified: 2018-04-11 14:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-22 05:13:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 546637 None None None Never

  None (edit)
Description Osma Ahvenlampi 2008-11-19 05:35:43 EST
Evolution 2.24 folder summary rewrite broke vfolders which use "status is not read" as a search parameter; opening the message marks it read, which causes it to disappear from the vfolder.

Fix just landed upstream. This is a pretty major regression for many Evo users, so flagging this for F10.

http://bugzilla.gnome.org/show_bug.cgi?id=546637#c23
Comment 1 Matthew Barnes 2008-11-19 08:15:37 EST
Will be included in Monday's 2.24.2 release.
Comment 2 Osma Ahvenlampi 2008-11-24 14:09:58 EST
Just installed these from Koji, killed all evolution processes and tried again: the bug is still there :(

evolution-2.24.2-1.fc10.i386.rpm
evolution-bogofilter-2.24.2-1.fc10.i386.rpm
evolution-conduits-2.24.2-1.fc10.i386.rpm
evolution-data-server-2.24.2-1.fc10.i386.rpm
evolution-spamassassin-2.24.2-1.fc10.i386.rpm
Comment 3 Bug Zapper 2008-11-26 00:35:58 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Matěj Cepl 2008-12-10 02:18:39 EST
This is bug is a show-stopper for me -- I hate when my MUA reads my emails instead of me.

Still alive and kicking with

[matej@viklef ~]$ rpm -qa evolution\*
evolution-perl-2.24.2-2.fc10.i386
evolution-remove-duplicates-0.0.4-1.fc10.i386
evolution-conduits-2.24.2-2.fc10.i386
evolution-data-server-doc-2.24.2-1.fc10.i386
evolution-remove-duplicates-debuginfo-0.0.4-1.fc10.i386
evolution-2.24.2-2.fc10.i386
evolution-debuginfo-2.25.1-2.fc11.i386
evolution-spamassassin-2.24.2-2.fc10.i386
evolution-bogofilter-2.24.2-2.fc10.i386
evolution-data-server-debuginfo-2.25.1-1.fc11.i386
evolution-data-server-2.24.2-1.fc10.i386
[matej@viklef ~]$ 

And I think dataloss in MUA deserves higher severity.
Comment 5 Osma Ahvenlampi 2008-12-10 04:19:35 EST
As the original reporter, I'd have to agree, but for the fact that the upstream fix turns out to be an ugly hack to a complete lemon summary rewrite. A FIX is to downgrade to Evolution 2.22 :(
Comment 6 Matthew Barnes 2009-06-21 09:05:24 EDT
Is this bug still present on Fedora 11 or later?
Comment 7 Osma Ahvenlampi 2009-06-22 05:13:17 EDT
seems that at least to a basic level, F11 evolution vfolders work. I haven't followed upstream comments on the implementation recently.

Note You need to log in before you can comment on or make changes to this bug.