This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 472214 - 'integer expression expected' errors occur during upgrade
'integer expression expected' errors occur during upgrade
Status: CLOSED DUPLICATE of bug 460878
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rpm (Show other bugs)
5.3
i386 Linux
high Severity medium
: rc
: ---
Assigned To: Panu Matilainen
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-19 07:55 EST by Marian Ganisin
Modified: 2008-12-02 05:37 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-02 05:37:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum update log (301.02 KB, text/plain)
2008-11-19 10:34 EST, Marian Ganisin
no flags Details

  None (edit)
Description Marian Ganisin 2008-11-19 07:55:15 EST
Description of problem:
Following messages are randomly occuring during system upgrade:
/var/tmp/rpm-tmp.20212: line 25: [: 391VERSION: integer expression expected
/var/tmp/rpm-tmp.78685: line 25: [: 27905VERSION: integer expression expected
/var/tmp/rpm-tmp.38126: line 25: [: 9376VERSION: integer expression expected

There isn't visible rule, which could help describe occurance, it's looks like it is really random. I saw it during upgrade of whole system (using anaconda or yum) for different packages (firstboot, NetworkManager-gnome).
Message is always same (doesn't matter which package), error is always on line 25, integer before 'VERSION' is always different (even if it occurs for same package in two different upgrades)

Version-Release number of selected component (if applicable):
RHEL5.3-Server-20081113.1
rpm-4.4.2.3-7.el5.i386

How reproducible:
No procedure to reproduce, it has random behavior. However it occurs during upgrade of whole system using yum or anaconda

Steps to Reproduce:
1. Install RHEL 5.2 Server (all the packages)
2. Upgrade to RHEL 5.3
Comment 2 Marian Ganisin 2008-11-19 10:34:03 EST
Here is link, to anaconda upgrade.log:
http://hank.test.redhat.com/autotest/testcases/rel-eng_RHEL5.3-Server-20081113.1_5-i386/anaconda-upgrade-RHEL-5-Server_U2-released_distill-distill-english-nfs-GUI-_Everything-Server/anamon/upgrade.log

Described issue occurs when upgrading firstboot-1.4.27.6-2.el5.i386.
Log of yum update against RHN is attached, issue occurs during cleanup of NetworkManager-gnome.
Comment 3 Marian Ganisin 2008-11-19 10:34:50 EST
Created attachment 324055 [details]
yum update log
Comment 4 Panu Matilainen 2008-11-19 11:40:49 EST
Looks like a dupe of bug 463921 to me.
Comment 5 Denise Dumas 2008-11-25 15:14:33 EST
Panu, can you please explain? And different error message - do we need addition to 463921 release note?
Comment 6 Brock Organ 2008-12-01 19:40:05 EST
looking at a similar upgrade:

http://hank.test.redhat.com/autotest/testcases/rel-eng_RHEL5.3-Server-20081120.1_5-i386/anaconda-upgrade-RHEL-5-Server_U2-released_distill-distill-english-nfs-GUI-_Everything-Server/anamon/upgrade.log

the error does not occur immediately after the firstboot package upgrade (as it did in the upgrade.log from comment #2:

Upgrading system-config-display-1.0.48-2.el5.noarch
Upgrading firstboot-1.4.27.7-1.el5.i386
Upgrading anaconda-runtime-11.1.2.157-1.i386
Upgrading xorg-x11-drv-i810-devel-1.6.5-9.20.el5.i386
/var/tmp/rpm-tmp.269: line 25: [: 543VERSION: integer expression expected

while a 3rd upgrade test case shows the error in yet a different spot:

http://hank.test.redhat.com/autotest/testcases/rel-eng_RHEL5.3-Server-20081120.1_5-i386/anaconda-upgrade-RHEL-5-Server_U2-released_distill-distill-english-ftp-TUI-_Everything-Server_VT/anamon/upgrade.log

Upgrading firstboot-1.4.27.7-1.el5.i386
Upgrading anaconda-runtime-11.1.2.157-1.i386
Upgrading xorg-x11-drv-i810-devel-1.6.5-9.20.el5.i386
/var/tmp/rpm-tmp.9994: line 25: [: 559VERSION: integer expression expected
Upgrading openldap-servers-2.3.43-3.el5.i386
Upgrading Deployment_Guide-en-US-5.2-11.noarch
Upgrading 30:bind-chroot-9.3.4-9.P1.el5.i386

without further debugging information, it is difficult to understand where the error is occuring, and how serious it impacts the upgrade ...
Comment 7 Brock Organ 2008-12-01 21:56:18 EST
yet a 4th upgrade shows:

http://hank.test.redhat.com/autotest/testcases/rel-eng_RHEL5.3-Server-20081120.1_5-i386/anaconda-upgrade-RHEL-5-Server_U2-released_distill-distill-english-http-VNC-_Everything-Server_VT_Cluster_Cluster/anamon/upgrade.log

Upgrading system-config-display-1.0.48-2.el5.noarch
Upgrading firstboot-1.4.27.7-1.el5.i386
Upgrading anaconda-runtime-11.1.2.157-1.i386
Upgrading xorg-x11-drv-i810-devel-1.6.5-9.20.el5.i386
/var/tmp/rpm-tmp.97465: line 25: [: 3995VERSION: integer expression expected
Upgrading openldap-servers-2.3.43-3.el5.i386
Upgrading Deployment_Guide-en-US-5.2-11.noarch
Upgrading 30:bind-chroot-9.3.4-9.P1.el5.i386

so in the first upgrade.log, the error occurred right after the firstboot entry, but each of the three following upgrade.logs have shown the error after the xorg-x11-drv-i810-devel package upgrade ...
Comment 8 Panu Matilainen 2008-12-02 05:37:33 EST
Oh, ok somewhat hasty judgement in comment #4, the first logs show symptoms from the glibc thingie too...

The real issue is bug in RHEL 5.2 openmpi-libs %preun scriptlet:

        if [ "$$VERSION" -ne "1.2.5" ]; then
            mpi-selector --unregister openmpi-1.2.5-gcc-i386 \
                --yes 2&>/dev/null
        fi

"$$VERSION" will expand to pid of the process + literal VERSION (such as "559VERSION"), which is not an integer expression. This happens to be precisely line 25 of the scriptlet.

So the bug which this *really* is duplicate of is bug 460878. The errors can't be helped as rpm is executing scriptlet of an already installed package, but it says in bug 460878 that the errors are deal with in the new package and are non-fatal.

*** This bug has been marked as a duplicate of bug 460878 ***

Note You need to log in before you can comment on or make changes to this bug.