Bug 472220 - fkp font does not display some english (plain ol' ascii) characters properly
fkp font does not display some english (plain ol' ascii) characters properly
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: artwiz-aleczapka-fonts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-19 08:53 EST by steve
Modified: 2008-11-24 17:35 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-24 17:35:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
string "_{}[]~%@" using fkp font on gnome-terminal (13.17 KB, image/png)
2008-11-19 08:53 EST, steve
no flags Details

  None (edit)
Description steve 2008-11-19 08:53:14 EST
Created attachment 324032 [details]
string "_{}[]~%@" using fkp font on gnome-terminal

Description of problem:
The fkp font does not display the following characters properly:
- with these, the bottom part is missing: _{}[] (for example, an underscore cannot even be seen)
- with these, the top part is missing: ~%@ (for example, a tilde cannot even be seen)

Version-Release number of selected component (if applicable):
artwiz-aleczapka-fonts-1.3-5.fc8.1.noarch

How reproducible:
Always

Steps to Reproduce:
1. Choose the fkp font as your gnome-terminal font
2. Try typing out "_{}[]~%@" in the terminal

Actual results:
I've attached an image of how the string "_{}[]~%@" is displayed on the
gnome-terminal.

Expected results:
At least the normal ascii characters should be displayed correctly using this
font.

Additional info:
Comment 1 Tom "spot" Callaway 2008-11-20 13:15:15 EST
This wasn't a gnome-terminal bug, the fkp font had some incomplete characters (and in the case of an underscore, no character at all). I've fixed this up, and updates should be hitting all branches shortly.

(I ended up packaging up the tool I used to make the edits, since it greatly simplified the process: https://bugzilla.redhat.com/show_bug.cgi?id=472418 )

Thanks for the report.
Comment 2 Fedora Update System 2008-11-20 13:30:21 EST
artwiz-aleczapka-fonts-1.3-6.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/artwiz-aleczapka-fonts-1.3-6.fc9
Comment 3 Fedora Update System 2008-11-20 13:30:25 EST
artwiz-aleczapka-fonts-1.3-6.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/artwiz-aleczapka-fonts-1.3-6.fc10
Comment 4 Fedora Update System 2008-11-20 13:30:28 EST
artwiz-aleczapka-fonts-1.3-6.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/artwiz-aleczapka-fonts-1.3-6.fc8
Comment 5 Fedora Update System 2008-11-21 06:00:40 EST
artwiz-aleczapka-fonts-1.3-6.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2008-11-21 06:01:59 EST
artwiz-aleczapka-fonts-1.3-6.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2008-11-22 11:56:33 EST
artwiz-aleczapka-fonts-1.3-6.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 steve 2008-11-24 17:25:10 EST
Hi Tom,

I tried the updated font today, but am sorry to report that it seems like you may have missed the "[" and "]" characters when submitting your fix.

All the other reported characters (ie: ~_@%{}) look neat !! Thanks for the work !

In addition to this I noticed that the back-tick character '`' ...shows up somewhat like a really small straight dash instead of a slanted tick.

Fixing this too would be much appreciated !

thanks a lot,
- steve
Comment 9 Tom "spot" Callaway 2008-11-24 17:35:54 EST
So, I'm not sure what you're expecting [] to look like in the fkp font, but the font design doesn't include the horizontal line ends, that's not an oversight, it is intentional.

I think that the back-tick is intentionally a high, short horizontal line, it doesn't show the same sort of clipping that some of the other characters had.

It would be possible to perhaps make a derived font that changed these items, but it wouldn't really be fkp anymore.

Note You need to log in before you can comment on or make changes to this bug.