Bug 472230 - Dozen packages are missing on Sat530 ISO
Dozen packages are missing on Sat530 ISO
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Release (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Devan Goodwin
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-19 09:39 EST by Miroslav Suchý
Modified: 2008-11-20 10:42 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-20 07:35:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2008-11-19 09:39:11 EST
Description of problem:
Dozen package are missing on Sat530 ISO

Version-Release number of selected component (if applicable):
Satellite-5.3.0-RHEL5-re20081117.0-i386-embedded-oracle.iso

How reproducible:
always

Steps to Reproduce:
1. mount this ISO
2 install.pl --disconnected
  
Actual results:
..
Installing packages. The log can be found in

        /var/log/rhn/rhn-installation.log

You can tail -f in another terminal to see the progress.
Running up2date -i ant antlr axis bcel classpathx-jaf classpathx-mail eclipse-ecj elfutils-libs geronimo-specs geronimo-specs-compat gjdoc jakarta-commons-beanutils jakarta-commons-codec jakarta-commons-collections jakarta-commons-daemon jakarta-commons-dbcp jakarta-commons-digester jakarta-commons-discovery jakarta-commons-el jakarta-commons-fileupload jakarta-commons-httpclient jakarta-commons-lang jakarta-commons-launcher jakarta-commons-logging jakarta-commons-modeler jakarta-commons-pool jakarta-commons-validator jakarta-oro jdom libXmu libXp libXpm libXtst log4j mx4j perl-BSD-Resource perl-IO-Socket-SSL perl-Net-SSLeay regexp struts tomcat5 tomcat5-common-lib tomcat5-jasper tomcat5-server-lib wsdl4j xalan-j2 xerces-j2 xml-commons xml-commons-apis xml-commons-resolver
It looks like installation of packages failed. The following are still
missing:

        ant
        antlr
        axis
        bcel
        classpathx-jaf
        classpathx-mail
        eclipse-ecj
        elfutils-libs
        geronimo-specs
        geronimo-specs-compat
        gjdoc
        jakarta-commons-beanutils
        jakarta-commons-codec
        jakarta-commons-collections
        jakarta-commons-daemon
        jakarta-commons-dbcp
        jakarta-commons-digester
        jakarta-commons-discovery
        jakarta-commons-el
        jakarta-commons-fileupload
        jakarta-commons-httpclient
        jakarta-commons-lang
        jakarta-commons-launcher
        jakarta-commons-logging
        jakarta-commons-modeler
        jakarta-commons-pool
        jakarta-commons-validator
        jakarta-oro
        java-1.4.2-gcj-compat
        jdom
        libXmu
        libXp
        libXpm
        libXtst
        log4j
        mx4j
        perl-BSD-Resource
        perl-IO-Socket-SSL
        perl-Net-SSLeay
        regexp
        struts
        tomcat5
        tomcat5-common-lib
        tomcat5-jasper
        tomcat5-jsp-2.0-api
        tomcat5-server-lib
        tomcat5-servlet-2.4-api
        wsdl4j
        xalan-j2
        xerces-j2
        xml-commons
        xml-commons-apis
        xml-commons-resolver

Please install them and rerun the Satellite installer. The log file

        /var/log/rhn/rhn-installation.log

might also have some useful information.


Expected results:
Packages are installed.
Comment 1 Jan Pazdziora 2008-11-19 09:47:13 EST
We'll probably need something added to comps. Changing component to Release, reassigning to Dennis.
Comment 2 Jan Pazdziora 2008-11-19 10:12:33 EST
Oops, did not manage the reassignment the first time, trying again.
Comment 3 Devan Goodwin 2008-11-19 14:06:13 EST
This is normal behaviour for a box that isn't registered anywhere. I think we can close this ticket, once the machine is registered these packages can be installed fine.
Comment 4 Clifford Perry 2008-11-19 14:12:34 EST
I am not sure if this is an ISO issue, but more a code issue with either installer or the fact not registered to RHN. 

The installation should go ahead and prompt you to install the packages manually, since they are part of RHEL. 

Sounds like install.pl - if we are broken. Otherwise mistake in installation. 

If its OK assign to Devan, since he is testing current new ISO's for review. 

Cliff
Comment 5 Jan Pazdziora 2008-11-19 14:16:46 EST
Mirek, is this RHEL 4 or RHEL 5? Because you mention that the ISO you've used is RHEL5 one, but the installer tries to run up2date, which does not sound correct.
Comment 6 Devan Goodwin 2008-11-19 14:38:46 EST
What were the contents of your /var/log/rhn-installation.log, and was this box registered somewhere?
Comment 7 Miroslav Suchý 2008-11-20 07:35:04 EST
Mea culpa, I has been ideed installing rhel5 iso on rhel4 machine.
Closing NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.