Bug 472250 - evolution 2.24.1.1 crashes on exit
evolution 2.24.1.1 crashes on exit
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-19 11:09 EST by Thomas J. Baker
Modified: 2008-11-20 04:54 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-20 04:54:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
thread apply all bt of crash (18.83 KB, application/octet-stream)
2008-11-19 11:09 EST, Thomas J. Baker
no flags Details
thread apply all bt of crash reattached to correct mime type (18.83 KB, text/plain)
2008-11-19 11:23 EST, Thomas J. Baker
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 561069 None None None Never

  None (edit)
Description Thomas J. Baker 2008-11-19 11:09:15 EST
Created attachment 324064 [details]
thread apply all bt of crash

Since the glibc-2.9-2 update on Monday, evolution seems to crash every time I exit it. This happens on three different systems running F10+rawhide. Crash log attached.
Comment 1 Thomas J. Baker 2008-11-19 11:23:14 EST
Created attachment 324071 [details]
thread apply all bt of crash reattached to correct mime type
Comment 2 Milan Crha 2008-11-19 12:35:18 EST
I see, maybe it's not related to the glib update, it crashes in IMAP provider, and even there are no details for it, I guess it's related to "expunge on exit" option in Edit->Preference->Mail Preferences->Empty trash folders on exit.
See the upstream bug [1] for more information. Just to be sure, can you try to disable that option and see what happens? Thanks in advance.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=561069
Comment 3 Thomas J. Baker 2008-11-19 13:55:16 EST
With it disabled, I no longer get a crash. Tested on two systems.
Comment 4 Milan Crha 2008-11-20 04:54:33 EST
Thanks for the update. I'm closing this as UPSTREAM. The fix will be included in next release, which is supposed to come next Monday.

Note You need to log in before you can comment on or make changes to this bug.