Bug 472261 - WARNING: at kernel/sysctl.c:1967 unregister_sysctl_table+0xc0/0xf7(); kernel-2.6.27.5-120.fc10.x86_64
WARNING: at kernel/sysctl.c:1967 unregister_sysctl_table+0xc0/0xf7(); kernel-...
Status: CLOSED DUPLICATE of bug 518939
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-19 12:17 EST by Tom London
Modified: 2009-10-26 08:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-26 08:26:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2008-11-19 12:17:21 EST
Description of problem:

Kernel Oops: http://www.kerneloops.org/submitresult.php?number=102979

Was trying to print on an "unconnected" parallel port printer.

Kernel failure message 1:
------------[ cut here ]------------
WARNING: at kernel/sysctl.c:1967 unregister_sysctl_table+0xc0/0xf7() (Not tainted)
Modules linked in: i915 drm rfcomm sco bridge stp bnep l2cap sunrpc nf_conntrack_netbios_ns ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 cpufreq_ondemand acpi_cpufreq freq_table fuse dm_multipath kvm_intel kvm uinput snd_hda_intel snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device arc4 ecb snd_pcm_oss snd_mixer_oss snd_pcm iwlagn snd_timer snd_page_alloc snd_hwdep iwlcore snd ppdev i2c_i801 sdhci_pci btusb usblp sdhci soundcore e1000e mac80211 firewire_ohci thinkpad_acpi parport_pc i2c_core iTCO_wdt mmc_core firewire_core video yenta_socket parport rfkill rsrc_nonstatic battery ac pcspkr iTCO_vendor_support output bluetooth hwmon crc_itu_t cfg80211 joydev sha256_generic cbc aes_x86_64 aes_generic dm_crypt crypto_blkcipher [last unloaded: microcode]
Pid: 4045, comm: hp Not tainted 2.6.27.5-120.fc10.x86_64 #1

Call Trace:
 [<ffffffff810418f2>] warn_on_slowpath+0x60/0x90
 [<ffffffff81331fe4>] ? _spin_unlock_irqrestore+0x27/0x3e
 [<ffffffff81041e93>] ? release_console_sem+0x1d0/0x1dc
 [<ffffffff81298886>] ? sock_destroy_inode+0x14/0x16
 [<ffffffff81048686>] ? unregister_sysctl_table+0xdf/0xf7
 [<ffffffff81048686>] ? unregister_sysctl_table+0xdf/0xf7
 [<ffffffff81048667>] unregister_sysctl_table+0xc0/0xf7
 [<ffffffff810b9c04>] ? __slab_free+0x83/0x28e
 [<ffffffffa01681e2>] ? pp_release+0x15e/0x168 [ppdev]
 [<ffffffff8113f44f>] ? selinux_file_free_security+0x1e/0x20
 [<ffffffffa007a7f0>] parport_device_proc_unregister+0x28/0x36 [parport]
 [<ffffffffa0078ac9>] parport_unregister_device+0xf/0x12c [parport]
 [<ffffffffa01681b9>] pp_release+0x135/0x168 [ppdev]
 [<ffffffff810c0d7f>] __fput+0xca/0x16d
 [<ffffffff810c0e37>] fput+0x15/0x17
 [<ffffffff810be2e1>] filp_close+0x67/0x72
 [<ffffffff8104328c>] put_files_struct+0x74/0xc8
 [<ffffffff81043328>] exit_files+0x48/0x51
 [<ffffffff81044c89>] do_exit+0x26a/0x8a0
 [<ffffffff81298f8e>] ? __sock_sendmsg+0x59/0x62
 [<ffffffff812998ce>] ? sock_sendmsg+0xc7/0xe0
 [<ffffffff81045341>] do_group_exit+0x82/0xaf
 [<ffffffff8104e70e>] get_signal_to_deliver+0x2b0/0x2dc
 [<ffffffff81010349>] ? sysret_signal+0x42/0x71
 [<ffffffff8100f42f>] do_notify_resume+0x90/0x93f
 [<ffffffff8133050e>] ? thread_return+0xab/0xd9
 [<ffffffff81332119>] ? _spin_lock_irqsave+0x2a/0x33
 [<ffffffff8105a18b>] ? getnstimeofday+0x3a/0x96
 [<ffffffff8105819e>] ? ktime_get_ts+0x49/0x4e
 [<ffffffff810581b4>] ? ktime_get+0x11/0x42
 [<ffffffff81057840>] ? update_rmtp+0x4c/0x61
 [<ffffffff8105807e>] ? hrtimer_nanosleep+0x8b/0xdd
 [<ffffffff81057855>] ? hrtimer_wakeup+0x0/0x21
 [<ffffffff810c71b3>] ? path_put+0x1d/0x21
 [<ffffffff81010349>] ? sysret_signal+0x42/0x71
 [<ffffffff81010707>] ptregscall_common+0x67/0xb0

---[ end trace 33121fe5eba9137c ]---


Here are the entries in /var/log/messages just before this:

Nov 19 09:10:26 tlondon parport0: io/hpmud/pp.c 627: unable to read device-id ret=-1
Nov 19 09:10:26 tlondon parport0: prnt/backend/hp.c 675: INFO: open device failed; will retry in 30 seconds...
Nov 19 09:10:45 tlondon kernel: usblp0: removed
Nov 19 09:10:47 tlondon python: hp-makeuri[4083]: warning: hp-makeuri should not be run as root.
Nov 19 09:10:56 tlondon parport0: io/hpmud/pp.c 627: unable to read device-id ret=-1
Nov 19 09:10:56 tlondon parport0: prnt/backend/hp.c 675: INFO: open device failed; will retry in 30 seconds...
Nov 19 09:11:27 tlondon parport0: io/hpmud/pp.c 627: unable to read device-id ret=-1
Nov 19 09:11:27 tlondon parport0: prnt/backend/hp.c 675: INFO: open device failed; will retry in 30 seconds...
Nov 19 09:11:54 tlondon kernel: ------------[ cut here ]------------




Version-Release number of selected component (if applicable):
kernel-2.6.27.5-120.fc10.x86_64

How reproducible:
Don't know

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bug Zapper 2008-11-26 00:36:58 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Tom London 2008-11-30 12:09:21 EST
Get this with kernel-2.6.27.7-130.fc10.x86_64 when I attempt to modify printer settings via CUPS/browser interface (i.e., https://localhost:631).


Nov 30 09:01:02 tlondon kernel: ------------[ cut here ]------------
Nov 30 09:01:02 tlondon kernel: WARNING: at kernel/sysctl.c:1967 unregister_sysctl_table+0xc0/0xf7() (Not tainted)
Nov 30 09:01:02 tlondon kernel: Modules linked in: lp i915 drm sco bridge stp bnep l2cap bluetooth sunrpc nf_conntrack_netbios_ns ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 cpufreq_ondemand acpi_cpufreq freq_table fuse dm_multipath kvm_intel kvm uinput snd_hda_intel arc4 snd_seq_dummy snd_seq_oss ecb snd_seq_midi_event snd_seq iwlagn snd_seq_device iwlcore snd_pcm_oss snd_mixer_oss mac80211 snd_pcm snd_timer snd_page_alloc sdhci_pci ppdev thinkpad_acpi sdhci snd_hwdep iTCO_wdt e1000e video firewire_ohci snd cfg80211 iTCO_vendor_support parport_pc output firewire_core i2c_i801 mmc_core parport yenta_socket crc_itu_t rfkill soundcore rsrc_nonstatic i2c_core hwmon pcspkr battery ac sha256_generic cbc aes_x86_64 aes_generic dm_crypt crypto_blkcipher [last unloaded: microcode]
Nov 30 09:01:02 tlondon kernel: Pid: 3511, comm: python Not tainted 2.6.27.7-130.fc10.x86_64 #1
Nov 30 09:01:02 tlondon kernel:
Nov 30 09:01:02 tlondon kernel: Call Trace:
Nov 30 09:01:02 tlondon kernel: [<ffffffff810418f2>] warn_on_slowpath+0x60/0x90
Nov 30 09:01:02 tlondon kernel: [<ffffffff810933a2>] ? __pagevec_free+0x29/0x3d
Nov 30 09:01:02 tlondon kernel: [<ffffffff8113e9e3>] ? avc_has_perm+0x4e/0x60
Nov 30 09:01:02 tlondon kernel: [<ffffffffa0065221>] ? parport_wait_peripheral+0x46/0x107 [parport]
Nov 30 09:01:02 tlondon kernel: [<ffffffff81048667>] unregister_sysctl_table+0xc0/0xf7
Nov 30 09:01:02 tlondon kernel: [<ffffffff8133269c>] ? unlock_kernel+0x2f/0x32
Nov 30 09:01:02 tlondon kernel: [<ffffffffa011da20>] ? pp_ioctl+0x7ad/0x7bf [ppdev]
Nov 30 09:01:02 tlondon kernel: [<ffffffffa00667f0>] parport_device_proc_unregister+0x28/0x36 [parport]
Nov 30 09:01:02 tlondon kernel: [<ffffffffa0064ac9>] parport_unregister_device+0xf/0x12c [parport]
Nov 30 09:01:02 tlondon kernel: [<ffffffffa011d1b9>] pp_release+0x135/0x168 [ppdev]
Nov 30 09:01:02 tlondon kernel: [<ffffffff810c0fc7>] __fput+0xca/0x16d
Nov 30 09:01:02 tlondon kernel: [<ffffffff810c107f>] fput+0x15/0x17
Nov 30 09:01:02 tlondon kernel: [<ffffffff810be529>] filp_close+0x67/0x72
Nov 30 09:01:02 tlondon kernel: [<ffffffff810be5e1>] sys_close+0xad/0xf0
Nov 30 09:01:02 tlondon kernel: [<ffffffff8101024a>] system_call_fastpath+0x16/0x1b
Nov 30 09:01:02 tlondon kernel:
Nov 30 09:01:02 tlondon kernel: ---[ end trace 0e22d177d447cbf1 ]---
Nov 30 09:01:02 tlondon setroubleshoot: SELinux is preventing hpfax (hplip_t) "read write" to anon_inode (anon_inodefs_t). For complete SELinux messages. run sealert -l 221be31e-530b-4c72-92d2-323a017c9fc9
Nov 30 09:01:14 tlondon kerneloops: Submitted 1 kernel oopses to www.kerneloops.org
Comment 3 Prarit Bhargava 2009-10-26 08:26:40 EDT

*** This bug has been marked as a duplicate of bug 518939 ***

Note You need to log in before you can comment on or make changes to this bug.