Bug 472294 - Music plays too fast on Dell Precision WorkStation 450
Music plays too fast on Dell Precision WorkStation 450
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-19 16:37 EST by Will Woods
Modified: 2009-05-27 16:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-27 16:59:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
alsa-info.txt from Dell Precision WorkStation 450 (14.34 KB, text/plain)
2008-11-19 16:37 EST, Will Woods
no flags Details

  None (edit)
Description Will Woods 2008-11-19 16:37:16 EST
Created attachment 324097 [details]
alsa-info.txt from Dell Precision WorkStation 450

My Dell Precision WorkStation 450 has one of those poor stupid ac'97 chips that misses its guess on the clock speed now and then. It should probably get added to the whitelist, as with the similar chip in bug 441087.

I'm attaching alsa-info.txt, but the relevant hardware info is:
PCI Subsys Vendor: 0x1028
PCI Subsys Device: 0x012d

The patch in bug 441087 has:
+   SND_PCI_QUIRK(0x1028, 0x01ad, "AD1981B", 48000),

So adding:
+   SND_PCI_QUIRK(0x1028, 0x012d, "AD1981B", 48000),

should fix this one.

As a workaround, I've put:
options snd_intel8x0 ac97_clock=48000
in /etc/modprobe.conf to ensure I get the right clock value.
Comment 1 Bug Zapper 2008-11-26 00:37:51 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Will Woods 2009-05-27 16:59:22 EDT
This seems to be fixed with current kernels.

Note You need to log in before you can comment on or make changes to this bug.