Bug 472311 - Nouveau driver doesn't work at all on GForce 9200 GM
Nouveau driver doesn't work at all on GForce 9200 GM
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
10
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-19 18:26 EST by Henry-Nicolas Tourneur
Modified: 2008-12-09 03:50 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-09 03:50:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xserver log (72.56 KB, text/plain)
2008-11-19 18:26 EST, Henry-Nicolas Tourneur
no flags Details
dmidecode (8.77 KB, text/plain)
2008-11-19 18:26 EST, Henry-Nicolas Tourneur
no flags Details
Xorg configuration file (1.06 KB, text/plain)
2008-11-19 18:27 EST, Henry-Nicolas Tourneur
no flags Details
lspci output (18.48 KB, text/plain)
2008-11-19 18:28 EST, Henry-Nicolas Tourneur
no flags Details
Kernel oops log when starting nouveau (15.34 KB, text/plain)
2008-11-24 11:56 EST, Henry-Nicolas Tourneur
no flags Details

  None (edit)
Description Henry-Nicolas Tourneur 2008-11-19 18:26:05 EST
Created attachment 324114 [details]
xserver log

Hi,

I'm trying to use the nouveau driver with Fedora 10 Rawhide (updated). I'm using it on a HP Pavillon DV5-1030eb (laptop so) with a GForce 9200GM. When X startup, I only get a black screen so the driver isn't working at all on my configuration.

The log file doesn't looks to show any particular thing (like if everything worked correctly).

I saw that this nouveau package is a checkout of the git of septembre, maybe using a more recent version might work (and if it doesn't work at all, you won't have anything to break).

I'm attaching several files as I don't know exactly what you need, if any information is missing, please tell me.
Comment 1 Henry-Nicolas Tourneur 2008-11-19 18:26:54 EST
Created attachment 324116 [details]
dmidecode
Comment 2 Henry-Nicolas Tourneur 2008-11-19 18:27:31 EST
Created attachment 324117 [details]
Xorg configuration file
Comment 3 Henry-Nicolas Tourneur 2008-11-19 18:28:03 EST
Created attachment 324118 [details]
lspci output
Comment 4 Henry-Nicolas Tourneur 2008-11-24 11:55:51 EST
Hi,

I did just found that when nouveau crashes, a kernel oops file is created in /tmp, so I'm posting an example of that oops file here.
Comment 5 Henry-Nicolas Tourneur 2008-11-24 11:56:42 EST
Created attachment 324504 [details]
Kernel oops log when starting nouveau
Comment 6 Bug Zapper 2008-11-26 00:38:37 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Henry-Nicolas Tourneur 2008-12-09 03:50:40 EST
98I'm closing this bug.
After speaking on IRC with the nouveau team, it appears that (looking at my logs) my card isn't currently supported. Since it is not supported, it is normal that nouveau faill to start and so, it is not a Red Hat or Fedora bug.
The only thing that might help them for now is to provide an mmio trace for this card.

Messages in logs looks like :
Dec  8 12:52:48 localhost kernel: [drm:nv50_graph_init_ctxctl] *ERROR* no ctxprog for chipset NV98
Dec  8 12:52:48 localhost kernel: [drm:nouveau_ioctl_getparam] *ERROR* called without init

Quite clear here, there is something missing for NV98.

Note You need to log in before you can comment on or make changes to this bug.