Bug 472341 - strace reporting weird return values on ppc
strace reporting weird return values on ppc
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: strace (Show other bugs)
5.3
ppc64 Linux
medium Severity medium
: rc
: ---
Assigned To: Roland McGrath
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-20 04:28 EST by Petr Šplíchal
Modified: 2016-05-31 21:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-23 05:58:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Šplíchal 2008-11-20 04:28:05 EST
When testing reposync bug 460694 (counting open file descriptors)
I encountered strange return values being reported for open/close
operations on ppc arch. The command itself seems to work well, so
I expect there's something wrong with strace.

Version-Release number of selected component (if applicable):
strace-4.5.16-1.el5.1
strace64-4.5.16-1.el5.1
yum-utils-1.1.10-9.el5

Steps to Reproduce:
1. yum install -y yum-utils
2. strace -e close reposync 2>&1 | head -33
  
Actual results:
close(3)                                = 4160393262
close(3)                                = 4160393569
close(3)                                = 4160408917
close(3)                                = 4160387839
close(3)                                = 4160399781
close(3)                                = 4160412110
close(3)                                = 264830976
close(4)                                = 4160028672
close(5)                                = 4160028672
close(6)                                = 4160028672
close(7)                                = 4160028672
close(8)                                = 4160028672
close(7)                                = 6
close(6)                                = 4291743451
close(7)                                = 4160028672
close(6)                                = 268959744
close(7)                                = 4160028672
close(8)                                = 4160028672
close(7)                                = 6
close(6)                                = 5
close(5)                                = 268567584
close(5)                                = 268692720
close(5)                                = 4160028672
close(7)                                = 4159635456
close(8)                                = 4159635456
close(9)                                = 4159635456
close(10)                               = 4159635456
close(9)                                = 4291731419
close(10)                               = 4159635456
close(9)                                = 8
close(8)                                = 7
close(7)                                = 6
close(6)                                = 5

Expected results:
close(3)                                = 0
close(3)                                = 0
close(3)                                = 0
close(3)                                = 0
close(3)                                = 0
close(3)                                = 0
close(3)                                = 0
close(4)                                = 0
close(5)                                = 0
close(6)                                = 0
close(7)                                = 0
close(8)                                = 0
close(7)                                = 0
close(6)                                = 0
close(7)                                = 0
close(6)                                = 0
close(7)                                = 0
close(8)                                = 0
close(7)                                = 0
close(6)                                = 0
close(5)                                = 0
close(5)                                = 0
close(5)                                = 0
close(7)                                = 0
close(8)                                = 0
close(9)                                = 0
close(10)                               = 0
close(9)                                = 0
close(10)                               = 0
close(9)                                = 0
close(8)                                = 0
close(7)                                = 0
close(6)                                = 0

Additional info:
On fresh RHEL5.3 I am not able to "strace reposync" at all.
Just get the following error message:
+++ killed by SIGTRAP +++

# rpm -q yum-utils strace
yum-utils-1.1.16-11.el5
strace-4.5.18-2.el5

Works without a problem on other architectures.
Comment 1 Andreas Schwab 2009-09-23 04:41:19 EDT
I cannot reproduce that.

Note You need to log in before you can comment on or make changes to this bug.