Bug 472353 - Back to GDM after suspend. Xorg crash
Back to GDM after suspend. Xorg crash
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
: 473823 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-20 07:17 EST by Sam Tygier
Modified: 2009-01-26 11:53 EST (History)
7 users (show)

See Also:
Fixed In Version: xorg-x11-drv-ati-6.9.0-63.fc10.i386
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-28 18:03:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log.old with backtrace (60.51 KB, text/plain)
2008-11-20 07:17 EST, Sam Tygier
no flags Details
xorg.conf (594 bytes, text/plain)
2008-11-20 07:18 EST, Sam Tygier
no flags Details
xorg logs after testing xorg-x11-drv-ati-6.9.0-62 from koji (15.70 KB, text/plain)
2008-12-09 10:05 EST, Greg Orlowski
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 13994 None None None Never

  None (edit)
Description Sam Tygier 2008-11-20 07:17:19 EST
Created attachment 324165 [details]
Xorg.0.log.old with backtrace

Description of problem:
After resuming from suspend I get to GDM rather than a password box to reenter my session (if i log back up and reopen firefox it asks me if i want to restore the previous session).

Xorg.0.log.old shows:

Backtrace:
0: /usr/bin/Xorg(xorg_backtrace+0x3b) [0x812bc5b]
1: /usr/bin/Xorg(xf86SigHandler+0x51) [0x80bcc81]
2: [0x110400]
3: /usr/lib/xorg/modules/drivers//radeon_drv.so [0x25e4cb]
4: /usr/lib/xorg/modules/drivers//radeon_drv.so(radeon_update_dri_buffers+0x6f) [0x25e60f]
5: /usr/lib/xorg/modules/drivers//radeon_drv.so(RADEONEnterVT+0xbb) [0x23008b]
6: /usr/bin/Xorg [0x80d1fd1]
7: /usr/bin/Xorg [0x80c4c74]
8: /usr/bin/Xorg(xf86Wakeup+0x3d3) [0x80bd993]
9: /usr/bin/Xorg(WakeupHandler+0x52) [0x8089c22]
10: /usr/bin/Xorg(WaitForSomething+0x1a3) [0x8128fa3]
11: /usr/bin/Xorg(Dispatch+0x7e) [0x8085bce]
12: /usr/bin/Xorg(main+0x47d) [0x806b71d]
13: /lib/libc.so.6(__libc_start_main+0xe5) [0x6f76d5]
14: /usr/bin/Xorg [0x806ab01]

Fatal server error:
Caught signal 11.  Server aborting

My graphics card is a radeon 7000
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M6 LY

I am running up to date rawhide (upgrade from F9 with preupgrade)


Version-Release number of selected component (if applicable):


How reproducible:
everytime


Steps to Reproduce:
1. log in
2. suspend (close lid, or press suspend button)
3. resume (open lid, or press Fn button)
  
Actual results:
Session gone, at GDM

Expected results:
Enter password, back in session

Additional info:
Thinkpad x31
Comment 1 Sam Tygier 2008-11-20 07:18:22 EST
Created attachment 324166 [details]
xorg.conf
Comment 2 Sam Tygier 2008-11-20 09:17:33 EST
I can also trigger the X crash with a VT switch.
CTRL+ALT+F2
CTRL+ALT+F1
Comment 3 Bug Zapper 2008-11-26 00:39:03 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Sam Tygier 2008-12-03 07:26:18 EST
this is probably related to or a dupe of Bug 473823
Comment 5 Greg Orlowski 2008-12-06 22:24:32 EST
I am also experiencing this problem. When I resume from suspend, my X crashes, and I am returned to the GDM login. I have (Dell D600):

$ lspci -v |grep -i radeon
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV250 [Mobility FireGL 9000] (rev 02) (prog-if 00 [VGA controller])
	Kernel modules: radeon, radeonfb

...
My Xorg.0.log.old after I try to resume from suspend:

...
Backtrace:
0: /usr/bin/Xorg(xorg_backtrace+0x3b) [0x812bc5b]
1: /usr/bin/Xorg(xf86SigHandler+0x51) [0x80bcc81]
2: [0x110400]
3: /usr/lib/xorg/modules/drivers//radeon_drv.so [0x2a04cb]
4: /usr/lib/xorg/modules/drivers//radeon_drv.so(radeon_update_dri_buffers+0x6f) [0x2a060f]
5: /usr/lib/xorg/modules/drivers//radeon_drv.so(RADEONEnterVT+0xbb) [0x2720db]
6: /usr/lib/xorg/modules//libxaa.so [0x32f718]
7: /usr/bin/Xorg [0x80d1fd1]
8: /usr/bin/Xorg [0x80c4c74]
9: /usr/bin/Xorg(xf86Wakeup+0x3d3) [0x80bd993]
10: /usr/bin/Xorg(WakeupHandler+0x52) [0x8089c22]
11: /usr/bin/Xorg(WaitForSomething+0x1a3) [0x8128fa3]
12: /usr/bin/Xorg(Dispatch+0x7e) [0x8085bce]
13: /usr/bin/Xorg(main+0x47d) [0x806b71d]
14: /lib/libc.so.6(__libc_start_main+0xe5) [0x9776d5]
15: /usr/bin/Xorg [0x806ab01]

Fatal server error:
Caught signal 11.  Server aborting
...

My grub.conf boot:
        kernel /vmlinuz-2.6.27.5-117.fc10.i686 ro root=UUID=e820d89c-a7f7-4a66-bff2-cfb76e95d28a rhgb quiet nopat nomodeset

(I get the same behavior with and without nopat and nomodeset... my graphics performance seems to be better with the additional 2 options, but it does not affect the bug).

Additionally, I initially had this RPM:
xorg-x11-drv-ati-6.9.0-59.fc10.i386.rpm

But I dug around for a newer version and found:
http://kojipkgs.fedoraproject.org/packages/xorg-x11-drv-ati/6.9.0/61.fc10/i386/xorg-x11-drv-ati-6.9.0-61.fc10.i386.rpm

When I install the newer RPM, I still have the problem (the above backtrace is from the newer version).

I initially had no xorg.conf, but I eventually installed:
system-config-display

And went with the default xorg.conf that it created, except I modified this section (does not affect the issue one way or another, but the XAA seems to improve my regular graphics rendering performance):

Section "Device"
        Identifier  "Videocard0"
        Driver      "radeon"
        Option          "AccelMethod" "XAA"
        Option          "AGPMode" "1"
        Option          "EnablePageFlip" "1"
        Option          "ColorTiling" "1"
EndSection

Otherwise, I do not have compiz or any fancy stuff like that enabled.

If you would like additional info or if you would like me to test out any changes you make, feel free to contact me.

THANKS!
Comment 6 Orion Poplawski 2008-12-07 22:45:52 EST
*** Bug 473823 has been marked as a duplicate of this bug. ***
Comment 7 Orion Poplawski 2008-12-07 22:52:12 EST
According to upstream bug report, this may be fixed.  Also, bug #471338 looks to be another dupe.
Comment 8 Orion Poplawski 2008-12-07 22:59:04 EST
Hmm, upstream patch has already been applied to latest fedora package, so looks to be different issue.
Comment 9 Dave Airlie 2008-12-08 22:36:40 EST
if you can please try the xorg-x11-drv-ati-6.9.0-62 when it lands in koji

that would help.
Comment 10 Sam Tygier 2008-12-09 04:48:39 EST
Thanks, that fixes it for me.
Comment 11 Sam Tygier 2008-12-09 08:05:31 EST
eeek. since rebooting x crashes as it starts.
can't do CTRL+ALT+F1. caps key does not light caps led. CTRL+ALT+Backspace, CTRL+ALT+DEL, magic sysreq do nothing. but Fn+PgUp turns on think light, and bightness controls work.

i can start the machine in runlevel 3

the last messages in the Xorg.0.log are 3 repeats of
(EE) RADEON(0): FIFO timed out, resetting engine ...
Comment 12 Sam Tygier 2008-12-09 08:22:29 EST
i have switch the driver to vesa in my xorg.conf. now i can log in normal (though the resolution is to low 800x600 instead of 1024x768 :-( )
Comment 13 Greg Orlowski 2008-12-09 10:05:04 EST
Created attachment 326325 [details]
xorg logs after testing xorg-x11-drv-ati-6.9.0-62 from koji
Comment 14 Greg Orlowski 2008-12-09 10:22:57 EST
This fixed the specific issue I was having, but there is a new quirk.

Old behavior (v61 and prior):
1) Login in GDM
2) Suspend with suspend button or pm-suspend
3) Wait 5 seconds
4) Upon resume from suspend, X crashes with backtrace in log (see comment #5).

New Behavior (v62 from koji):
1) Login in GDM
2) Suspend with suspend button or pm-suspend
3) Wait 5 seconds
4) Upon resume from suspend, laptop goes into suspend again
5) Upon second resume, everything works (X does not crash, my logged-in session is still there along with the gnome-terminal that I had running)

I tried again, same behavior. I rebooted and retried a few times (first time I just went to runlevel 2 installed v62 rpm, reloaded radeon driver, went back to runlevel 5). Behavior is consistently reproducible.

I attached my Xorg.0.log*. I don't know if this will help you with the double-suspend. Let me know if you want any other logs (gotta run to work now so I don't have time to poke around more).

FYI, I looked at the quirk* options in my pm-suspend log (using defaults):
$ grep quirk pm-suspend.log 
Initial commandline parameters: --quirk-vbestate-restore
--quirk-vbemode-restore
--quirk-vbe-post

THANKS!
Comment 15 Risto Kankkunen 2008-12-09 16:59:12 EST
I tried v62 also, but it was totally unusable. I was able to switch virtual terminals, but even after waiting several minutes the GDM login screen was not completely drawn. The CPU fan started making noise, so I guess X was consuming all the CPU.

The login dialog and its buttons were only partially drawn while the background appeared properly. After waiting for a while, some black horizontal stripes appeared. Just poking around blindly seemed to work (I guess I hit the reboot button), but the dialog was so poorly rendered that I couldn't figure out how to log in.

I have now switched to the vesa driver with 1400x1050 resolution and this works without problems and is much faster than any of the radeon drivers I tried with F10.
Comment 16 Greg Orlowski 2008-12-09 18:32:01 EST
Dave Airlie,

For me, on my hardware:

$ lspci -v |grep -i radeon
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV250 [Mobility
FireGL 9000] (rev 02) (prog-if 00 [VGA controller])
 Kernel modules: radeon, radeonfb

This is now fixed in v62 from koji. What I wrote in comment #13+#14 does not apply to the radeon driver crash. The new issue that I'm having (suspend again after resume), is some issue with the way gnome power manager handles my suspend keypress event -- a dup of:

https://bugzilla.redhat.com/show_bug.cgi?id=475585

If I set G-P-M to "do nothing" when the suspend button is pressed and suspend with # pm-suspend, my laptop properly suspends once, resumes when I press the power button, and then stays resumed. And X does not crash.

thanks so much!
Comment 17 Orion Poplawski 2008-12-10 15:09:10 EST
For me, on my hardware:

$ lspci -v |grep -i radeon
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500] (prog-if 00 [VGA controller])
        Kernel modules: radeon, radeonfb

VT switching works.  However, I suspended and on resume the display (external Dell LCD monitor on VGA) was completely distorted - white noise with a big blocky blinking cursor thing.  This I think is a longstanding problem with this card.

Rebooted and then the problem was much text was not being displayed, often replaced by something like an underscore _.  Restarts would change what was or was not displayed, but always not correct.  Went back to old driver.
Comment 18 Risto Kankkunen 2008-12-23 10:29:20 EST
(In reply to comment #15)
> I tried v62 also, but it was totally unusable.

I tried v63 now and it seems to fix the problems I had before: VT switching and suspend/resume work without lock-up, display artefacts or other problems. Even the window redraw speed seems much better, even if I have Firefox eating 60% CPU all the time. 

Thanks for your efforts.
Comment 19 Sam Tygier 2008-12-25 12:21:08 EST
xorg-x11-drv-ati-6.9.0-63.fc10.i386 solves all my problems. radeon does not hang at gdm, and VT switching works.

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M6 LY

thanks

Note You need to log in before you can comment on or make changes to this bug.