Bug 472357 - Conflicts with dahdi-tools
Conflicts with dahdi-tools
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dahdi-tools (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeffrey C. Ollie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-20 07:44 EST by Michael Schwendt
Modified: 2009-05-08 08:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-08 08:04:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2008-11-20 07:44:25 EST
dahdi-tools-libs  from  dahdi-tools
    provides libtonezone.so.1.0
zaptel-lib  from  zaptel
    provides libtonezone.so.1.0
    required by: asterisk-dahdi-1.6.0.1-2.fc10.i386
    required by: callweaver-zaptel-1.2.0.1-1.2.fc10.i386
    required by: dahdi-tools-devel-2.0.0-1.fc10.i386
    required by: zaptel-devel-1.4.12.1-1.fc10.i386
    required by: zaptel-lib-1.4.12.1-1.fc10.i386
    required by: zaptel-utils-1.4.12.1-1.fc10.i386
    required by: dahdi-tools-libs-2.0.0-1.fc10.i386

Maybe especially harmful in shortest-package-name-wins scenarios.
Both store the lib in %_libdir.


With a brief look I discovered a typo in your spec file:

  Conflicts:      zaptel-libs

The package is called: zaptel-lib


Adventurous.
Comment 1 Jeffrey C. Ollie 2008-11-20 07:53:10 EST
dahdi-tools is intended to replace zaptel, but can't until CallWeaver has been ported over.  I'll get the conflicts sorted out but other than that I'm not sure what else to do.
Comment 2 Michael Schwendt 2008-11-24 06:43:11 EST
Fix the "Conflicts" should suffice. EPEL is also affected.
Comment 3 Bug Zapper 2008-11-26 00:39:24 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Michael Schwendt 2009-02-10 07:45:17 EST
zaptel-utils-1.4.12.1-1.fc10.i386  in  rawhide-development-i386
  File conflict with: dahdi-tools-2.1.0.2-4.fc11.i386
     /usr/share/man/man8/fxotune.8.gz
Comment 5 Michael Schwendt 2009-02-10 09:38:50 EST
=> zaptel-1.4.12.1-1.fc10.src.rpm
=> zaptel-utils-1.4.12.1-1.fc10.i386 in rawhide-development-i386
  File conflict with: dahdi-tools-2.1.0.2-4.fc11.i386
     /usr/sbin/fxotune
     /usr/share/man/man8/fxotune.8.gz
Comment 6 Michael Schwendt 2009-05-08 08:04:39 EDT
Fix committed to devel (F12).

Note You need to log in before you can comment on or make changes to this bug.