Bug 472381 - Oracle Server Stops Functioning After Satellite 530 Installation
Oracle Server Stops Functioning After Satellite 530 Installation
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
530
All Linux
high Severity high
: ---
: ---
Assigned To: Michael Mráka
Steve Salevan
:
Depends On:
Blocks: 463876
  Show dependency treegraph
 
Reported: 2008-11-20 10:52 EST by Devan Goodwin
Modified: 2009-09-10 14:53 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:53:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Devan Goodwin 2008-11-20 10:52:48 EST
During Satellite installation, rhnsat db is created and populated successfully, installer moves through cert validation etc, then reports an error starting tomcat.

Uncovered in ISO Satellite-5.3.0-RHEL4-re20081119.2-i386-embedded-oracle.iso

catalina.out log reports many errors related to: java.sql.SQLException: Connections could not be acquired from the underlying database!

[root@rlx-0-18 satiso]# sqlplus rhnsat/rhnsat@rhnsat

SQL*Plus: Release 10.2.0.3.0 - Production on Thu Nov 20 10:48:57 2008

Copyright (c) 1982, 2006, Oracle.  All Rights Reserved.

ERROR:
ORA-12541: TNS:no listener

[root@rlx-0-18 satiso]# ps aux | grep ora
oracle   10081  0.0  0.6 362708 13160 ?      Ss   09:45   0:00 ora_pmon_rhnsat
oracle   10083  0.0  0.5 362068 10948 ?      Ss   09:45   0:00 ora_psp0_rhnsat
oracle   10085  0.0  1.3 362068 28516 ?      Ss   09:45   0:00 ora_mman_rhnsat
oracle   10087  0.0  1.7 365420 37156 ?      Ss   09:45   0:00 ora_dbw0_rhnsat
oracle   10089  0.0  5.2 363752 108864 ?     Ss   09:45   0:01 ora_dbw1_rhnsat
oracle   10091  0.1  0.7 377628 15552 ?      Ss   09:45   0:07 ora_lgwr_rhnsat
oracle   10093  0.0  0.9 363788 19888 ?      Ss   09:45   0:01 ora_ckpt_rhnsat
oracle   10095  0.0  2.7 363704 57500 ?      Ss   09:45   0:02 ora_smon_rhnsat
oracle   10097  0.0  0.9 362124 18972 ?      Ss   09:45   0:00 ora_reco_rhnsat
oracle   10099  0.0  1.3 363728 29016 ?      Ss   09:45   0:01 ora_cjq0_rhnsat
oracle   10101  0.0  2.4 364912 49856 ?      Ss   09:45   0:01 ora_mmon_rhnsat
oracle   10103  0.0  0.7 362072 14840 ?      Ss   09:45   0:00 ora_mmnl_rhnsat
oracle   10108  0.0  0.5 362072 12120 ?      Ss   09:45   0:00 ora_qmnc_rhnsat
oracle   10169  0.0  0.6 362100 14280 ?      Ss   09:45   0:00 ora_q000_rhnsat
oracle   10171  0.0  0.5 362100 11472 ?      Ss   09:45   0:00 ora_q001_rhnsat
root     12706  0.0  0.0  4756  656 pts/1    S+   10:52   0:00 grep ora
Comment 1 Devan Goodwin 2008-11-20 10:56:16 EST
Restarting all services doesn't seem to help the situation, and unable to find any errors of interest in /rhnsat/admin/rhnsat/bdump/alert_rhnsat.log or /var/log/rhn/rhn_database.log.
Comment 2 Devan Goodwin 2008-11-20 11:32:46 EST
Problem appears to be specific to RHEL 4. RHEL 5 ISO installed ok.
Comment 4 Clifford Perry 2008-11-23 18:32:53 EST
not sure why the listener process is not running. 

/opt/apps/oracle/web/product/10.2.0/db_1/listener.log shows nothing obvious to me. 

still poking about.
Comment 8 Michael Mráka 2008-11-28 09:19:28 EST
Backported changes from spacewalk 0.4.
Package spacewalk-setup-0.3.11-1.
Comment 9 Steve Salevan 2009-01-21 15:27:01 EST
Looks like we're good on re20081223.2:

Installation complete.
Visit https://fjs-0-04.rhndev.redhat.com to create the RHN Satellite administrator account.
[root@fjs-0-04 ~]# sqlplus rhnsat/rhnsat@rhnsat

SQL*Plus: Release 10.2.0.4.0 - Production on Wed Jan 21 15:26:00 2009

Copyright (c) 1982, 2007, Oracle.  All Rights Reserved.


Connected to:
Oracle Database 10g Enterprise Edition Release 10.2.0.4.0 - Production
With the Partitioning, OLAP, Data Mining and Real Application Testing options

SQL>
Comment 11 Brandon Perkins 2009-09-10 14:53:27 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.