Bug 472436 - Libnotify plugin in emesene isn't working properly
Libnotify plugin in emesene isn't working properly
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: emesene (Show other bugs)
10
All Linux
medium Severity low
: ---
: ---
Assigned To: Allisson Azevedo
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-20 15:22 EST by Luis Nabais
Modified: 2009-10-05 10:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-05 10:03:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luis Nabais 2008-11-20 15:22:52 EST
Description of problem:
The libnotify plugin in emesene isn't working properly. When the notification is closed an error message pops up saying:
"TypeError: on_notify_close() takes exactly 2 arguments (3 given)"
Once the error message is shown a restart of the application is needed to disable the plugin and resume normal usage.

Version-Release number of selected component (if applicable):
emesene v1.0.1 - release 3.fc10
libnotify v0.4.4 - release 12.fc10
notify-python v0.1.1 - release 4.fc10
notification-daemon v0.3.7.90 - release 1.svn3009.fc10

How reproducible:
Error message is shown every time a notification is closed/disappears.

Steps to Reproduce:
1. Enable the Libnotify plugin in emesene.
2. wait for a notification (recieve a mesene, someone logging in/out, etc...).
3. close said notification or wait for it to timeout.
  
Actual results:
An error message is shown when the notification is closed/disappears.

Expected results:
Notification closed without an error message.
Comment 1 Bug Zapper 2008-11-26 00:42:04 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Caius Chance 2008-12-01 01:17:33 EST
Have you tested also on x86 (32 bit)?

I have tested on x86 but the bug is not reproducible. 

Needs time to prep a 64-bit env for testing.
Comment 3 Luis Nabais 2008-12-01 10:01:50 EST
I can reproduce it on a freshly installed i686 Fedora 10 System:
emesene v1.0.1 - release 3.fc10
libnotify v0.4.4 - release 12.fc10
notify-python v0.1.1 - release 4.fc10
notification-daemon v0.3.7.90 - release 1.svn3009.fc10
Comment 4 Caius Chance 2008-12-01 21:43:43 EST
I tested on both 32-bit and 64-bit F10 but I still could not reproduce that. I have exactly same version of packages you listed above.
Comment 5 Luis Nabais 2008-12-02 04:43:21 EST
strange... I just made a clean install on a VM, installed emesene and enabled the libnotify plugin. As soon as a notification was shown and it disapeared the error popped up.

I tried before and after updating the system, didn't install any extra packages.

I doubt it has something to do with my language settings (Portuguese)...
Comment 6 Caius Chance 2008-12-08 20:12:16 EST
I guess libnotify or notify-python has changed the number of parameters on on_notify_close(), according to the error log.

We should clone this bug to author's tracker system as well.
Comment 7 Fedora Admin XMLRPC Client 2009-02-09 05:23:31 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 8 Allisson Azevedo 2009-10-05 09:28:25 EDT
You can confirm this bug against emesene 1.5?
Comment 9 Luis Nabais 2009-10-05 09:57:14 EDT
The bug seems to be fixed now.
Comment 10 Allisson Azevedo 2009-10-05 10:03:15 EDT
Ok, thanks for your report :)

Note You need to log in before you can comment on or make changes to this bug.