Bug 472462 - Traceback on upgrade from F8 w/kernel-xen installed
Traceback on upgrade from F8 w/kernel-xen installed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:68e32a6f81e0df07e...
:
: 474974 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-20 18:16 EST by Will Woods
Modified: 2009-08-03 10:56 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-21 15:21:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (102.46 KB, text/plain)
2008-11-20 18:16 EST, Will Woods
no flags Details
Attached traceback automatically from anaconda. (79.40 KB, text/plain)
2009-01-13 11:45 EST, Aaron
no flags Details
Attached traceback automatically from anaconda. (183.70 KB, text/plain)
2009-01-14 08:39 EST, Anton N. Petrov
no flags Details
Attached traceback automatically from anaconda. (123.59 KB, text/plain)
2009-01-22 22:32 EST, Luis Barreiro
no flags Details
Attached traceback automatically from anaconda. (145.35 KB, text/plain)
2009-01-23 12:59 EST, Larry
no flags Details
Attached traceback automatically from anaconda. (134.26 KB, text/plain)
2009-03-15 12:53 EDT, DiGGeR2
no flags Details
Attached traceback automatically from anaconda. (81.40 KB, text/plain)
2009-05-14 00:03 EDT, Michael Cronenworth
no flags Details
Attached traceback automatically from anaconda. (126.66 KB, text/plain)
2009-05-19 00:31 EDT, David Freeman
no flags Details
Attached traceback automatically from anaconda. (126.66 KB, text/plain)
2009-05-19 01:06 EDT, David Freeman
no flags Details
Attached traceback automatically from anaconda. (174.88 KB, text/plain)
2009-08-03 05:06 EDT, Diego
no flags Details
Attached traceback automatically from anaconda. (174.83 KB, text/plain)
2009-08-03 05:17 EDT, Diego
no flags Details

  None (edit)
Description Will Woods 2008-11-20 18:16:43 EST
This bug was filed automatically by anaconda.
Comment 1 Will Woods 2008-11-20 18:16:47 EST
Created attachment 324254 [details]
Attached traceback automatically from anaconda.
Comment 2 Will Woods 2008-11-20 19:44:44 EST
It looks like this only happens if you have kernel-xen installed. Removing kernel-xen (and installing kernel-PAE, just for fun) worked around the traceback.
Comment 3 Chris Lumens 2008-11-21 15:21:49 EST
This will be fixed in the next build of anaconda.
Comment 4 Aaron 2009-01-13 11:45:19 EST
Created attachment 328889 [details]
Attached traceback automatically from anaconda.
Comment 5 Anton N. Petrov 2009-01-14 08:39:55 EST
Created attachment 328986 [details]
Attached traceback automatically from anaconda.
Comment 6 Anton N. Petrov 2009-01-14 10:51:14 EST
(In reply to comment #2)
> It looks like this only happens if you have kernel-xen installed. Removing
> kernel-xen (and installing kernel-PAE, just for fun) worked around the
> traceback.

Not exactly...
I don't have  kernel-xen installed, but get the same result.
I had realtime kernel (Planet CCRMA) installed and removing it doesn't help :(
Comment 7 Luis Barreiro 2009-01-22 22:32:40 EST
Created attachment 329773 [details]
Attached traceback automatically from anaconda.
Comment 8 Larry 2009-01-23 12:59:09 EST
Created attachment 329861 [details]
Attached traceback automatically from anaconda.
Comment 9 DiGGeR2 2009-03-15 12:53:40 EDT
Created attachment 335263 [details]
Attached traceback automatically from anaconda.
Comment 10 Michael Cronenworth 2009-05-14 00:03:44 EDT
Created attachment 343907 [details]
Attached traceback automatically from anaconda.
Comment 11 Michael Cronenworth 2009-05-14 02:29:14 EDT
I got this on an F9->F10 preupgrade attempt. The kernel package was not pulled in by preupgrade, but downloading it manually did not help (yes, it was added to the install repo). I run "kernel" by default (not kernel-xen, not kernel-PAE). I tried installing kernel-PAE and that did not help either. Anyone upgrading off the soon to be unsupported F9 might run into this. I had to do a manual yum update instead (download F10 release RPMs and yum update).
Comment 12 David Freeman 2009-05-19 00:31:55 EDT
Created attachment 344562 [details]
Attached traceback automatically from anaconda.
Comment 13 David Freeman 2009-05-19 01:06:00 EDT
Created attachment 344564 [details]
Attached traceback automatically from anaconda.
Comment 14 Chris Lumens 2009-06-01 16:37:04 EDT
*** Bug 474974 has been marked as a duplicate of this bug. ***
Comment 15 Diego 2009-08-03 05:06:51 EDT
Created attachment 355971 [details]
Attached traceback automatically from anaconda.
Comment 16 Diego 2009-08-03 05:17:15 EDT
Created attachment 355973 [details]
Attached traceback automatically from anaconda.
Comment 17 Diego 2009-08-03 07:01:54 EDT
i don't have xen kernel installed.
Comment 18 Will Woods 2009-08-03 10:56:02 EDT
This bug is fixed in preupgrade-1.1.0. Try installing the Fedora 9 package of preupgrade-1.1.0: 

http://download.fedoraproject.org/pub/fedora/linux/updates/9/i386.newkey/preupgrade-1.1.0-1.fc9.noarch.rpm

or just upgrade normally using a CD/DVD image.

Note You need to log in before you can comment on or make changes to this bug.