Bug 472467 - [RHEL5.3] kernel-xen Floating point exception on 32bit para-virt guest
[RHEL5.3] kernel-xen Floating point exception on 32bit para-virt guest
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rpm (Show other bugs)
5.3
i386 Linux
high Severity high
: rc
: ---
Assigned To: Panu Matilainen
BaseOS QE
https://rhts.redhat.com/testlogs/3693...
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-20 19:18 EST by Jeff Burke
Modified: 2009-01-20 15:48 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 15:48:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RHTS xml. Reproducer (4.00 KB, text/plain)
2008-11-20 19:18 EST, Jeff Burke
no flags Details

  None (edit)
Description Jeff Burke 2008-11-20 19:18:56 EST
Created attachment 324260 [details]
RHTS xml. Reproducer

Description of problem:
  While running the kerneltier1 tests we see random failures on several tests. The kernel kabi, The LTP SELinux test. It was determined that this failure is a result of an underlying rpm failure.

Version-Release number of selected component (if applicable):
 2.6.18-124.el5xen

How reproducible:
 Always

Steps to Reproduce:
1. Install a i386 Dom0 and DomU(para-virt) guest. Use the latest distro tree RHEL5.3-Server-20081105.1
2. ssh into the guest run the following command
3. while true; do rpm -qf /etc/redhat-release; done
  
Actual results:

Floating point exception
Floating point exception
Floating point exception
Floating point exception
Floating point exception
redhat-release-5Server-5.3.0.2
redhat-release-5Server-5.3.0.2
redhat-release-5Server-5.3.0.2
redhat-release-5Server-5.3.0.2
redhat-release-5Server-5.3.0.2
redhat-release-5Server-5.3.0.2
redhat-release-5Server-5.3.0.2
redhat-release-5Server-5.3.0.2
redhat-release-5Server-5.3.0.2
Floating point exception
Floating point exception
Floating point exception
Floating point exception

Expected results:
 The rpm query should complete every time

Additional info:
 Attached is a RHTS XML script that reproduces the issue. Using the selinux test.
Comment 1 Jeff Burke 2008-11-20 19:33:43 EST
On the test systems we received the following message:

type=ANOM_ABEND msg=audit(1227210458.430:12): auid=4294967295 uid=0 gid=0 ses=4294967295 subj=root:system_r:rpm_t:s0 pid=15372 comm="rpmq" sig=8

Which translate to this:

type=ANOM_ABEND msg=audit(11/20/08 14:47:38.430:12) : auid=unset uid=root gid=root ses=4294967295 subj=root:system_r:rpm_t:s0 pid=15372 comm=rpmq sig=Floating point exception
Comment 2 Mike Gahagan 2008-11-21 08:40:31 EST
This apperantly affects yum as well.. although it might be rpm failing behind the scenes.
Comment 3 Chris Lalancette 2008-11-24 07:52:23 EST
Jeff,
     Hm, I can't reproduce this at all.  I've tried:

1) i386 pv guest on x86_64 dom0, hand installed - can't reproduce
2) i386 pv on i386 dom0, hand-installed - can't reproduce
3) i386 pv on i386 dom0, hand-installed with RHEL5.3-Server-20081105.1 tree - can't reproduce
4) RHTS XML script above, then logging into the guests - can't reproduce

I'm not sure if it's hardware specific or something, but I'll probably have to get some additional information on exactly which machines caused this problem for you.

Chris Lalancette
Comment 20 Gurhan Ozen 2008-12-03 13:42:06 EST
rpm-4.4.2.3-9.el5 fixes the issue. 
# uname -a;rpm -q rpm
Linux hp-xw6800-01.rhts.bos.redhat.com 2.6.18-124.el5xen #1 SMP Mon Nov 17 17:34:42 EST 2008 i686 i686 i386 GNU/Linux
rpm-4.4.2.3-9.el5

I've run ntpdate clock.redhat.com; rpm for over 600 times and all passed.
Comment 23 errata-xmlrpc 2009-01-20 15:48:28 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0079.html

Note You need to log in before you can comment on or make changes to this bug.