Bug 472481 - BONDING_OPT cause no syntax error, but create R-R bonding
BONDING_OPT cause no syntax error, but create R-R bonding
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: initscripts (Show other bugs)
5.2
All Linux
medium Severity low
: rc
: ---
Assigned To: initscripts Maintenance Team
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-20 22:14 EST by masanari iida
Modified: 2008-11-21 10:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-21 10:00:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description masanari iida 2008-11-20 22:14:47 EST
Description of problem:

When I set "BONDING_OPT="mode=1", 
system configured the bonding as "Round-Robin" 
I know I should have set "BONDING_OPTS".

Expected result would be either 
a) Syntax error while network initialize.
b) Set Active-Backup mode, even though option name 
"BONDING_OPT" is wrong.


FYI, if I set BONDING_OPTS="mode=1", 
the system configure the bonding as "active-backup"
This is expected.

It is because this symptom happen with configuration mistake,
so I don't consider this is a serious bug.
But currently /usr/share/doc/initscript-<version>/sysconfig.txt
doesn't explain what is correct, so we don't know what to do.
I have opened other BZ 472480 for documentation missing.

Version-Release number of selected component (if applicable):
RHEL 5.2
initscripts-8.45.19.EL-1

How reproducible:
Always

Steps to Reproduce:
1. Configure bonding.
Set ifcfg-bond0 as follow. 
 
BONDING_OPT="mode=1 primary=eth0 miimon=200"

2. Restart network.
  
Actual results:
Bonding was set R-R mode.


Expected results:
a) Syntax error 
b) Set Active-Backup mode, even though option name 
"BONDING_OPT" is wrong.



Additional info:
Comment 1 Bill Nottingham 2008-11-21 10:00:23 EST
That's not how configuration parameters work for initscripts - if you give a parameter the wrong name, it's just ignored. (Such as if you used IPADDRESS rather than IPADDR.)

Note You need to log in before you can comment on or make changes to this bug.