Bug 472488 - Unexpected behavior of ifconfig in RHTS environment
Unexpected behavior of ifconfig in RHTS environment
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: net-tools (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Zdenek Prikryl
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-20 23:59 EST by Ian Kent
Modified: 2009-03-19 05:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-19 05:01:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test ifconfig on RHEL-5.2 based install (1.61 KB, text/plain)
2008-11-26 23:16 EST, Ian Kent
no flags Details
Test ifconfig on RHEL-5.1 based install (585 bytes, text/plain)
2008-11-26 23:17 EST, Ian Kent
no flags Details
Test ifconfig on Fedora 8 based install (1.49 KB, text/plain)
2008-11-26 23:18 EST, Ian Kent
no flags Details
Test ifconfig on Fedora 9 based install (1.02 KB, text/plain)
2008-11-26 23:18 EST, Ian Kent
no flags Details

  None (edit)
Description Ian Kent 2008-11-20 23:59:44 EST
Description of problem:

I've observed unexpected behavior of ifconfig within the RHTS
test environment.

For example:
ifconfig lo:1 \
    address 192.168.128.1 \
    netmask 255.255.252.0 \
    broadcast 192.168.129.255

returns:
address: Unknown host
ifconfig: `--help' gives usage information.

Whereas 
ifconfig lo:1 \
    192.168.128.1 \
    netmask 255.255.252.0 \
    broadcast 192.168.129.255

works fine.

The former syntax works fine on Fedira 9 and a RHEL-5.2 install
that I have with the same revision of net-tools as is included
in the RHTS build (net-tools-1.60-78.el5) so I'm really not
sure of the source of the problem. I've logged this against
net-tools as a starting point.

I believe both of these syntaxes should work fine everywhere
(is that right?).

The RHTS build being used (in this case) was RHEL5.3-Server-20081119.nightly.

And the library dependencies of ifconfig were (containing
package revisions included in brackets):
linux-gate.so.1 =>  (oops, missed this one?)
libselinux.so.1 => /lib/libselinux.so.1 (libselinux-1.33.4-5.1.el5)
libc.so.6 => /lib/libc.so.6 (glibc-2.5-33)
libdl.so.2 => /lib/libdl.so.2 (glibc-2.5-33)
libsepol.so.1 => /lib/libsepol.so.1 (libsepol-1.15.2-1.el5)
/lib/ld-linux.so.2 (glibc-2.5-33)

I've updated the RHTS test script to work around this so this
report is for information in case we need to fix something prior
to the 5.3 release.

Ian
Comment 1 Zdenek Prikryl 2008-11-26 03:45:40 EST
Hello,
I tried to reproduce this bug, but I didn't succeeded. The syntax with "address" doesn't work at all. So, can you give me an access to the machine where this syntax works?

Thanks

Zdenek
Comment 2 Ian Kent 2008-11-26 23:15:03 EST
(In reply to comment #1)
> Hello,
> I tried to reproduce this bug, but I didn't succeeded. The syntax with
> "address" doesn't work at all. So, can you give me an access to the machine
> where this syntax works?

No. I work remotely so that's not possible but it shouldn't be
hard to find a contradiction in the way this works.

See the examples I'm uploading.
Comment 3 Ian Kent 2008-11-26 23:16:06 EST
Created attachment 324824 [details]
Test ifconfig on RHEL-5.2 based install
Comment 4 Ian Kent 2008-11-26 23:17:10 EST
Created attachment 324825 [details]
Test ifconfig on RHEL-5.1 based install
Comment 5 Ian Kent 2008-11-26 23:18:11 EST
Created attachment 324826 [details]
Test ifconfig on Fedora 8 based install
Comment 6 Ian Kent 2008-11-26 23:18:53 EST
Created attachment 324827 [details]
Test ifconfig on Fedora 9 based install
Comment 7 Ian Kent 2008-11-26 23:23:34 EST
I don't really care which syntax is used but I don't like surprises
like this between installs when developing RHTS tests because it
needlessly costs time I don't have.

So you tell me, which syntax is the one that should be enforced?
The yays appear to outnumber the nays AFAICS.
Comment 8 Zdenek Prikryl 2008-11-27 09:22:49 EST
The "address" syntax shouldn't work. ifconfig succeeds only if "address" is translated to IP. Please, could you try this?

$ ifconfig lo:1 address netmask 255.255.252.0 broadcast 192.168.129.255 && ifconfig

and

$ cat /etc/hosts

Anyway, use only syntax without "address"!

Thanks
Comment 9 Zdenek Prikryl 2009-03-19 05:01:40 EDT
It seems, that you found the problem, so I'm closing the bug.

Note You need to log in before you can comment on or make changes to this bug.