Bug 472503 - webcam does not work as expected with newer kernels
webcam does not work as expected with newer kernels
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-21 02:57 EST by Eli Wapniarski
Modified: 2008-11-26 08:36 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-26 08:36:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eli Wapniarski 2008-11-21 02:57:13 EST
kernel-2.6.27.5-41.fc9.x86_64

libv4l-0.5.4-1.fc9.i386.rpm (koji)
libv4l-0.5.4-1.fc9.x86_64.rpm (koji)


WEBCAM: Logitech quickcam

Modules loaded
--------------
gspca_spca561 gspca_main compat_ioctl32 videodev v4l1_compat


kopete and ekiga works when loaded with

LD_PRELOAD=/usr/lib64/libv4l/v4l1compat.so kopete -caption "%c" %u
LD_PRELOAD=/usr/lib64/libv4l/v4l1compat.so ekiga

Other minor problems:

1) When I close access to the web cam the pilot light on the camera
   goes out even though the camera still seems to work

2) Only one application can access the camera at a time.

   a) If I run kopete first then kopete will have access to the camera.
      If I then run ekiga the display shows green.

   b) If I run ekiga first, then ekiga has access to the camera.
      If I then run kopete. kopete crashes alltogether.


skype crashes when trying to access the camera when using

LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
Comment 1 Hans de Goede 2008-11-26 08:36:35 EST
(In reply to comment #0)
> kernel-2.6.27.5-41.fc9.x86_64
> 
> libv4l-0.5.4-1.fc9.i386.rpm (koji)
> libv4l-0.5.4-1.fc9.x86_64.rpm (koji)
> 
> 
> WEBCAM: Logitech quickcam
> 
> Modules loaded
> --------------
> gspca_spca561 gspca_main compat_ioctl32 videodev v4l1_compat
> 
> 
> kopete and ekiga works when loaded with
> 
> LD_PRELOAD=/usr/lib64/libv4l/v4l1compat.so kopete -caption "%c" %u
> LD_PRELOAD=/usr/lib64/libv4l/v4l1compat.so ekiga
> 
> Other minor problems:
> 
> 1) When I close access to the web cam the pilot light on the camera
>    goes out even though the camera still seems to work
> 

That is a feature not a bug, the light indicates if videodata is actually being streamed. So if you close the app showing the camstream the light goes off.

> 2) Only one application can access the camera at a time.
> 

Yes, that is normal video4linux behavior.

>    a) If I run kopete first then kopete will have access to the camera.
>       If I then run ekiga the display shows green.
> 
>    b) If I run ekiga first, then ekiga has access to the camera.
>       If I then run kopete. kopete crashes alltogether.
> 

Apps misbehaving when they get -EBUSY errors is not the drivers problem.

> skype crashes when trying to access the camera when using
> 
> LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype

skyoe works for me and a lot of other users with an spca561 based cam, do you have the latest skype? Anyways I cannot help you with that as skype is closed source software and as such not supported by Fedora.

Note You need to log in before you can comment on or make changes to this bug.