Bug 472526 - Need to clean out non-functional pieces of qpidc-perftest
Need to clean out non-functional pieces of qpidc-perftest
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: distribution (Show other bugs)
1.0
All Linux
medium Severity medium
: 1.1
: ---
Assigned To: Nuno Santos
Kim van der Riet
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-21 10:10 EST by Jeff Needle
Modified: 2013-09-12 18:10 EDT (History)
2 users (show)

See Also:
Fixed In Version: qpidc-perftest-0.3.724474
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-04 10:37:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test case for tools from qpidc-perftest package (997 bytes, text/plain)
2008-12-11 05:07 EST, Jan Sarenik
no flags Details

  None (edit)
Description Jeff Needle 2008-11-21 10:10:57 EST
qpidc-perftest rpm needs a haircut.  Nuno has details in e-mail.

# fanout_perftest
/usr/bin/run_test: line 16: /usr/bin/vg_check: No such file or directory

# /usr/bin/multiq_perftest
/usr/bin/run_test: line 16: /usr/bin/vg_check: No such file or directory

# python_tests
WARNING: No python tests. /usr/bin/../../../python not found.

# quick_perftest
/usr/bin/run_test: line 16: /usr/bin/vg_check: No such file or directory

# quick_topictest
/usr/bin/quick_topictest FAILED:
/usr/bin/quick_topictest: line 4: ./topictest: No such file or directory
(works if CWD is /usr/bin)

# run-unit-tests
/usr/bin/run-unit-tests: line 28: ./run_test: No such file or directory

# cd /usr/bin/
# run-unit-tests
ERROR: ld.so: object '.libs/libdlclose_noop.so' from LD_PRELOAD cannot be preloaded: ignored.
./run_test: line 16: /usr/bin/vg_check: No such file or directory

# run_perftest
expr: syntax error
/usr/bin/run_test: line 16: /usr/bin/vg_check: No such file or directory

# shared_perftest
/usr/bin/run_test: line 16: /usr/bin/vg_check: No such file or directory

# start_broker
/usr/bin/run_test: line 16: /usr/bin/vg_check: No such file or directory

# stop_broker
/usr/bin/stop_broker: line 8: ../qpidd: No such file or directory
egrep: qpidd.log: No such file or directory

# topic_perftest
/usr/bin/run_test: line 16: /usr/bin/vg_check: No such file or directory

# topictest
Start subscriber 9
Start subscriber 8
Start subscriber 7
Start subscriber 6
Start subscriber 5
Start subscriber 3
Start subscriber 2
Start subscriber 4
Start subscriber 1
Start subscriber 0
/usr/bin/topictest: line 33: ./topic_publisher: No such file or directory

(works if CWD is /usr/bin)

client_test, latencytest, perftest, txtest, topic_listener, and topic_publisher seem fine.  The shell scripts should go.
Comment 1 Nuno Santos 2008-12-01 15:57:49 EST
Fixed in distcvs, qpidc.spec rev 1.86 (for RHEL4 and RHEL5)
Comment 3 Jan Sarenik 2008-12-11 05:07:21 EST
Created attachment 326597 [details]
Test case for tools from qpidc-perftest package

I have tested it on all the supported systems and archs, that
means both RHEL 5.2 and 4.7, i368 and x86_64. See the attached
script which I used for testing even as a non-privileged user.

I have not included output of test-472526.sh because in the
following transcript, because it was the same on all the machines:

RHEL4.7 i386 - nec-em3.rhts.bos
===============================
[root@nec-em3 ~]# rpm -qa | grep qpid
qpidc-perftest-0.4.725317-5.el4
qpidc-0.4.725317-5.el4
qpidd-0.4.725317-5.el4

RHEL4.7 x86_64 - nec-em12.rhts.bos
==================================
[root@nec-em12 ~]# rpm -qa | grep qpid
qpidc-perftest-0.4.725317-5.el4
qpidd-0.4.725317-5.el4
qpidc-0.4.725317-5.el4

RHEL5.2 i368 - <my_local_machine>
=================================
slanina:~# rpm -qa | grep qpid
qpidd-0.4.725317-2.el5
qpidc-perftest-0.4.725317-2.el5
qpidc-0.4.725317-2.el5

RHEL5.2 x86_64 - nec-em16.rhts.bos
==================================
[jasan@nec-em16 ~]$ rpm -qa | grep qpid
qpidc-0.3.724474-2.el5
qpidd-0.3.724474-2.el5
qpidc-perftest-0.3.724474-2.el5
Comment 5 errata-xmlrpc 2009-02-04 10:37:38 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0035.html

Note You need to log in before you can comment on or make changes to this bug.