Bug 472530 - (SpeedyGhost) System clock slower in new kernel
System clock slower in new kernel
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Triaged
Depends On:
  Show dependency treegraph
Reported: 2008-11-21 10:28 EST by SpeedyGhost
Modified: 2009-12-18 01:54 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-12-18 01:54:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
/var/log/dmesg on old kernel (19.51 KB, text/plain)
2008-11-25 13:59 EST, SpeedyGhost
no flags Details
/var/log/dmesg on new kernel (23.36 KB, text/plain)
2008-11-25 14:01 EST, SpeedyGhost
no flags Details

  None (edit)
Description SpeedyGhost 2008-11-21 10:28:58 EST
Description of problem:
    I have fully updated Fedora 9 on my laptop Fujitsu Siemens Amilo PRO V2035 and my system clock is slower, on one minute it's missing about 2.5 seconds, in /proc/interrupts 'LOC: xxxx Local timer interrupts' xxxx is increasing very fast. I have that problem also with kernel, tried also on older kernel ( but there is ok, timer and system time is working fine. I was thinking first that it's problem with my bios or CMOS battery, but today I bought a new battery and problem is same, tried also on Knoppix live and there is also ok.

Additional info:
    Here is a link on my Smolt profile:
Comment 1 Chuck Ebbert 2008-11-25 10:52:27 EST
Can you get the boot messages from the old and new kernels?

1. Boot the old kernel, then attach the file /var/log/dmesg to this bug.
2. Do the same with the new kernel.
Comment 2 SpeedyGhost 2008-11-25 13:59:57 EST
Created attachment 324647 [details]
/var/log/dmesg on old kernel
Comment 3 SpeedyGhost 2008-11-25 14:01:33 EST
Created attachment 324648 [details]
/var/log/dmesg on new kernel
Comment 4 SpeedyGhost 2008-11-25 14:04:16 EST
Here it is, as you asked, from old and new kernel.

Comment 5 SpeedyGhost 2009-02-28 12:32:01 EST
Fedora 10, i686 - same problem :(
Comment 6 SpeedyGhost 2009-03-02 12:21:50 EST
Problem solved! :)

added 'hpet=force' to kernel line in grub, so problem is with clocksource. In available_clocksource was 'acpi_pm jiffies tsc'. It was using acpi_pm and with that clock was slower about 2 seconds on a minute, when I changed to jiffies, then system halted, with 'tsc' as clocksource system clock was faster about half second on a minute and with forced 'hpet' on boot clock is ok. Only it boots little slower than usual, first halts about minute or two and then continues with normal boot.
Comment 7 Luis Claudio R. Goncalves 2009-03-19 14:05:47 EDT
Just a note from the newest dmesg (comment #3) you posted here:

   Linux version 
   HPET not enabled in BIOS. You might try hpet=force boot option

Stress on "HPET not enabled in BIOS". I believe that if you enable HPET in your BIOS you won't need the boot parameters.

Also, yes, this TSC has been ruled as untable during boot (the same dmesg) because it halts on idle:

   Marking TSC unstable due to TSC halts in idle
Comment 8 Bug Zapper 2009-11-18 02:58:59 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 9 Bug Zapper 2009-12-18 01:54:35 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.