Bug 472534 - no plugins installed when kernel is updated
no plugins installed when kernel is updated
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-21 10:49 EST by Dennis Gilmore
Modified: 2008-12-03 10:46 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-03 10:46:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logged transaction from /var/log/messages (77.25 KB, text/plain)
2008-11-21 11:25 EST, Dennis Gilmore
no flags Details

  None (edit)
Description Dennis Gilmore 2008-11-21 10:49:00 EST
Description of problem:

doing a yum upate from F-9 to rawhide I saw the following

Installing     : kernel                                      [ 752/2199]
The default plymouth plugin (.so) doesn't exist

the plymouth plugins were not installed before plymouth or the kernel.  so mkinitrd could not find them to install into the initrd


Version-Release number of selected component (if applicable):

plymouth-0.6.0-0.2008.11.17.3.fc10.x86_64
Comment 1 Ray Strode [halfline] 2008-11-21 11:01:38 EST
do you have the whole transaction?
Comment 2 Ray Strode [halfline] 2008-11-21 11:02:55 EST
oh also, did you have rhgb installed before doing the upgrade?
Comment 3 Dennis Gilmore 2008-11-21 11:24:57 EST
looks like rhgb was not previously installed.
Comment 4 Dennis Gilmore 2008-11-21 11:25:54 EST
Created attachment 324319 [details]
logged transaction from /var/log/messages
Comment 5 Ray Strode [halfline] 2008-11-21 11:47:13 EST
so we currently have:

        PLUGIN_NAME=$(basename $(readlink ${LIBDIR}/plymouth/default.so) .so)
        if [ -z "$PLUGIN_NAME" ]; then
                $0 --reset
                PLUGIN_NAME=$(basename $(readlink ${LIBDIR}/plymouth/default.so) .so)
        fi

but the condition can never succeed.  Should be 

if [ "$PLUGIN_NAME" = ".so" ]; then
Comment 6 Ray Strode [halfline] 2008-11-21 11:52:47 EST
Fixed upstream:

http://cgit.freedesktop.org/plymouth/commit/?id=711636ec6a46dd8d7a9ab44a124d59bc38111d72
Comment 7 Bug Zapper 2008-11-26 00:43:44 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.