Bug 472589 - pm-hibernate does nothing if serial console is enabled
pm-hibernate does nothing if serial console is enabled
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dbus (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Matthias Clasen
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-21 16:10 EST by Orion Poplawski
Modified: 2014-06-25 16:48 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-25 16:48:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of dbus-daemon while pm-hibernate is run (43.36 KB, text/plain)
2008-12-19 15:54 EST, Orion Poplawski
no flags Details
pm-suspend.log (51.06 KB, text/plain)
2009-01-22 00:52 EST, Ben Gamari
no flags Details

  None (edit)
Description Orion Poplawski 2008-11-21 16:10:41 EST
Description of problem:

Configured serial console by putting "console=ttyS0,115200" into the boot line.  pm-hibernate then runs through hibernate and thaw hooks without attempting to hibernate.  It appears that:

                remove_suspend_lock 200
                dbus-send --system --print-reply \
                    --dest=org.freedesktop.Hal \
                    --type=method_call \
                    /org/freedesktop/Hal/devices/computer \
                    org.freedesktop.Hal.Device.SystemPowerManagement.Hibernate

does not work.  No idea why.

Version-Release number of selected component (if applicable):
pm-utils-0.99.3-6.el5.19

How reproducible:
everytime
Comment 1 Phil Knirsch 2008-12-19 10:28:45 EST
Is dbus running properly on the system?
Comment 2 Orion Poplawski 2008-12-19 15:53:26 EST
# ps -fe | grep dbus
dbus      2132     1  0 Dec18 ?        00:00:00 dbus-daemon --system

If I run the dbus-send command by hand in my ssh session, it goes into hibernate.

Is this an authorization issue?  dbus need to be running on the console, but it isn't with the serial console enabled?
Comment 3 Orion Poplawski 2008-12-19 15:54:25 EST
Created attachment 327496 [details]
strace of dbus-daemon while pm-hibernate is run
Comment 4 Ben Gamari 2009-01-13 10:40:53 EST
(In reply to comment #0)
> Configured serial console by putting "console=ttyS0,115200" into the boot line.
>  pm-hibernate then runs through hibernate and thaw hooks without attempting to
> hibernate. 

Does this also happen with pm-suspend in your case?
Comment 5 Orion Poplawski 2009-01-13 12:08:40 EST
# pm-suspend
Error: kernel cannot suspend to ram.
Comment 6 Ben Gamari 2009-01-22 00:52:54 EST
Created attachment 329693 [details]
pm-suspend.log

It turns out running PM_DEBUG=true pm-suspend provides an interesting log file. I'm a little dead at the moment but I'll try taking a closer look at it tomorrow.
Comment 8 RHEL Product and Program Management 2014-03-07 08:33:10 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 9 Orion Poplawski 2014-03-07 09:58:17 EST
I'm no longer using EL5
Comment 10 Ondrej Vasik 2014-06-25 16:48:03 EDT
Thanks for reply, closing WONTFIX for RHEL 5.

Note You need to log in before you can comment on or make changes to this bug.