Bug 47259 - install of kernel-headers-2.2.19-6.2.7 conflicts with file from package glibc-devel-2.1.3-22
install of kernel-headers-2.2.19-6.2.7 conflicts with file from package glibc...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
ftp://updates.redhat.com/6.2/en/os/i3...
:
Depends On: 26809
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-04 03:27 EDT by Hugh Bragg
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-04 03:28:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hugh Bragg 2001-07-04 03:27:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.19-6.2.1 i686; Nav)

Description of problem:
[root@rhl hugh]# rpm -Uhv kernel-headers-2.2.19-6.2.7.i386.rpm
kernel-source-2.2.19-6.2.7.i386.rpm
Preparing...                ###########################################
[100%]
file /usr/src/linux-2.2.19/include/scsi/scsi.h from install of
kernel-headers-2.2.19-6.2.7 conflicts with file from package
glibc-devel-2.1.3-22
file /usr/src/linux-2.2.19/include/scsi/scsi_ioctl.h from install of
kernel-headers-2.2.19-6.2.7 conflicts with file from package
glibc-devel-2.1.3-22
file /usr/src/linux-2.2.19/include/scsi/sg.h from install of
kernel-headers-2.2.19-6.2.7 conflicts with file from package
glibc-devel-2.1.3-22

How reproducible:
Always

Steps to Reproduce:
1. rpm -Fhv glibc-devel-2.1.3-22.i386.rpm
2. rpm -Fhv kernel-headers-2.2.19-6.2.7.i386.rpm
3. cannot install kernel-headers-2.2.19-6.2.7.i386.rpm
	

Actual Results:  cannot install kernel-headers-2.2.19-6.2.7.i386.rpm, the
latest updates

Additional info:

I currently have these kernal packages installed:
[root@rhl hugh]# rpm -qa | grep kernel
kernel-headers-2.2.19-6.2.1
kernel-2.2.19-6.2.7
kernel-source-2.2.19-6.2.1
kernel-utils-2.2.19-6.2.7
Comment 1 Hugh Bragg 2001-07-13 02:41:55 EDT
This is solved. The problem was created when installing kernel-source-2.2.17-14.i386.rpm. There was no seperate kernel-header package and in order for it to satisfy the rpm dependancies I had to create a soft link from /usr/src/linux/include/scsi to /usr/include/scsi. When upgrading to kernel-source-2.2.19-6.2.1.i386.rpm, there was no conflict with glibc-devel-2.1.3-22  reported, only when upgrading to kernel-source-2.2.19-6.2.7.i386.rpm was the issue reported by rpm.  
The fix was to remove the soft link.

Note You need to log in before you can comment on or make changes to this bug.