Bug 472612 - AttributeError: 'module' object has no attribute 'err'
AttributeError: 'module' object has no attribute 'err'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: smolt (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-21 20:25 EST by Mads Kiilerich
Modified: 2009-03-06 09:43 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-06 09:43:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch fixing typo (609 bytes, patch)
2008-11-21 20:25 EST, Mads Kiilerich
no flags Details | Diff
reversed reverse patch (609 bytes, patch)
2008-11-21 20:26 EST, Mads Kiilerich
no flags Details | Diff

  None (edit)
Description Mads Kiilerich 2008-11-21 20:25:06 EST
Created attachment 324391 [details]
patch fixing typo

Description of problem:

https://www.redhat.com/archives/fedora-test-list/2008-November/msg01077.html

[olivares@asus-amd64-athlon ~]$ smoltSendProfile 
Unable to save UUID, continuing...
Traceback (most recent call last):
  File "/usr/bin/smoltSendProfile", line 35, in <module>
    from scan import scan, rating
  File "/usr/share/smolt/client/scan.py", line 30, in <module>
    h = smolt.Hardware()
  File "/usr/share/smolt/client/smolt.py", line 359, in __init__
    self.devices[udi] = Device(props)
  File "/usr/share/smolt/client/smolt.py", line 134, in __init__
    self.UUID = getUUID()
  File "/usr/share/smolt/client/smolt.py", line 1015, in getUUID
    sys.err.write(_('Your UUID file could not be created: %s\n' % e))
AttributeError: 'module' object has no attribute 'err'


Version-Release number of selected component (if applicable):

smolt-1.1.1.1-9.fc10.noarch
Comment 1 Mads Kiilerich 2008-11-21 20:26:57 EST
Created attachment 324392 [details]
reversed reverse patch
Comment 2 Bug Zapper 2008-11-26 00:45:10 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Mads Kiilerich 2009-03-06 09:43:35 EST
It looks like it has been fixed for smolt-1.2-4.fc11.noarch

Closing

Note You need to log in before you can comment on or make changes to this bug.