This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 472638 - Could not find GNOME pixmap file /usr/share/icons/gnome/24x24/apps/evolution-mail.png
Could not find GNOME pixmap file /usr/share/icons/gnome/24x24/apps/evolution-...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-22 06:16 EST by Ralf Corsepius
Modified: 2009-02-06 01:24 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-06 01:24:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2008-11-22 06:16:29 EST
Description of problem:

Evolution on rawhide/FC10 has problems with its icons:

(evolution:3707): Bonobo-WARNING **: Could not find GNOME pixmap file /usr/share/icons/gnome/24x24/apps/evolution-mail.png

(evolution:3707): Bonobo-WARNING **: Could not find GNOME pixmap file /usr/share/icons/gnome/24x24/apps/evolution-tasks.png


Version-Release number of selected component (if applicable):
evolution-2.24.1-2.fc10.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. run evolution in a terminal
2. watch output
  
Actual results:
c.f. above
Comment 1 Ralf Corsepius 2008-11-22 06:40:00 EST
# find /usr/share -name evolution-mail.png
/usr/share/icons/hicolor/24x24/apps/evolution-mail.png
/usr/share/icons/hicolor/32x32/apps/evolution-mail.png
/usr/share/icons/hicolor/22x22/apps/evolution-mail.png
/usr/share/icons/hicolor/16x16/apps/evolution-mail.png
/usr/share/icons/hicolor/48x48/apps/evolution-mail.png

=> An apparent packaging bug somewhere.
Comment 2 Matthew Barnes 2008-11-22 09:24:09 EST
What version of gnome-icon-theme do you have?  It used to carry these icons.
Comment 3 Ralf Corsepius 2008-11-22 11:58:12 EST
Should be current rawhide/fc10:

# rpm -qf /usr/share/icons/hicolor/48x48/apps/evolution-*.png
evolution-2.24.1-2.fc10.x86_64
evolution-2.24.1-2.fc10.x86_64
evolution-2.24.1-2.fc10.x86_64

# rpm -q gnome-icon-theme
gnome-icon-theme-2.24.0-1.fc10.noarch

# rpm -ql gnome-icon-theme | grep evolution
<nothing>
Comment 4 Bug Zapper 2008-11-26 00:47:08 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Matthew Barnes 2008-11-28 15:08:31 EST
Do you still see these warnings after upgrading to evolution-2.24.2?

gnome-icon-theme stopped shipping those two files sometime during Fedora 10 development, and Evolution _started_ shipping those same two files shortly thereafter.  I'm wondering if that may have confused your icon cache.  If so, installing the next point release should straighten things out.
Comment 6 Ralf Corsepius 2008-12-19 02:11:42 EST
(In reply to comment #5)
> Do you still see these warnings after upgrading to evolution-2.24.2?
No, amongst the still many nuisances with evolution, at least these warnings
are gone.

> gnome-icon-theme stopped shipping those two files sometime during Fedora 10
> development, and Evolution _started_ shipping those same two files shortly
> thereafter.  I'm wondering if that may have confused your icon cache.
I don't know. Indeed, I am facing icon cache issues with the gnome desktop in general.
Comment 7 Eddie Lania 2008-12-25 07:28:16 EST
rpm -qa |grep evolution
beagle-evolution-0.3.8-13.fc10.i386
evolution-exchange-2.24.2-1.fc10.i386
evolution-webcal-2.23.91-1.fc10.i386
evolution-data-server-devel-2.24.2-1.fc10.i386
evolution-data-server-2.24.2-1.fc10.i386
evolution-sharp-0.18.1-1.fc10.i386
evolution-data-server-doc-2.24.2-1.fc10.i386
evolution-help-2.24.2-2.fc10.i386
evolution-2.24.2-2.fc10.i386

rpm -qa |grep -i gnome-icon
gnome-icon-theme-2.24.0-1.fc10.noarch

** (evolution:3394): DEBUG: mailto URL command: evolution --component=mail %s
** (evolution:3394): DEBUG: mailto URL program: evolution

(evolution:3394): Bonobo-WARNING **: Could not find GNOME pixmap file /usr/share/icons/gnome/24x24/apps/evolution-mail.png

(evolution:3394): Bonobo-WARNING **: Could not find GNOME pixmap file /usr/share/icons/gnome/24x24/apps/evolution-mail.png

(evolution:3394): Bonobo-WARNING **: Could not find GNOME pixmap file /usr/share/icons/gnome/24x24/apps/evolution-mail.png

(evolution:3394): Bonobo-WARNING **: Could not find GNOME pixmap file /usr/share/icons/gnome/24x24/apps/evolution-mail.png

(evolution:3394): Bonobo-WARNING **: Could not find GNOME pixmap file /usr/share/icons/gnome/24x24/apps/evolution-mail.png

(evolution:3394): Bonobo-WARNING **: Could not find GNOME pixmap file /usr/share/icons/gnome/24x24/apps/evolution-tasks.png

(evolution:3394): Bonobo-WARNING **: Could not find GNOME pixmap file /usr/share/icons/gnome/24x24/apps/evolution-tasks.png

(evolution:3394): Bonobo-WARNING **: Could not find GNOME pixmap file /usr/share/icons/gnome/24x24/apps/evolution-mail.png

(evolution:3394): Bonobo-WARNING **: Could not find GNOME pixmap file /usr/share/icons/gnome/24x24/apps/evolution-tasks.png
libnm_glib_nm_state_cb: dbus returned an error.
  (org.freedesktop.DBus.Error.ServiceUnknown) The name org.freedesktop.NetworkManager was not provided by any .service files

(evolution:3394): Bonobo-WARNING **: Could not find GNOME pixmap file /usr/share/icons/gnome/24x24/apps/evolution-mail.png

(evolution:3394): Bonobo-WARNING **: Could not find GNOME pixmap file /usr/share/icons/gnome/24x24/apps/evolution-tasks.png

(evolution:3394): Bonobo-WARNING **: Could not find GNOME pixmap file /usr/share/icons/gnome/24x24/apps/evolution-mail.png

(evolution:3394): Bonobo-WARNING **: Could not find GNOME pixmap file /usr/share/icons/gnome/24x24/apps/evolution-tasks.png

(evolution:3394): Bonobo-WARNING **: Could not find GNOME pixmap file /usr/share/icons/gnome/24x24/apps/evolution-mail.png

(evolution:3394): Bonobo-WARNING **: Could not find GNOME pixmap file /usr/share/icons/gnome/24x24/apps/evolution-tasks.png

(evolution:3394): Bonobo-WARNING **: Could not find GNOME pixmap file /usr/share/icons/gnome/24x24/apps/evolution-mail.png

(evolution:3394): Bonobo-WARNING **: Could not find GNOME pixmap file /usr/share/icons/gnome/24x24/apps/evolution-tasks.png

(evolution:3394): Bonobo-WARNING **: Could not find GNOME pixmap file /usr/share/icons/gnome/24x24/apps/evolution-mail.png

(evolution:3394): Bonobo-WARNING **: Could not find GNOME pixmap file /usr/share/icons/gnome/24x24/apps/evolution-tasks.png

(evolution:3394): Bonobo-WARNING **: Could not find GNOME pixmap file /usr/share/icons/gnome/24x24/apps/evolution-mail.png

(evolution:3394): Bonobo-WARNING **: Could not find GNOME pixmap file /usr/share/icons/gnome/24x24/apps/evolution-tasks.png

(evolution:3394): Bonobo-WARNING **: Could not find GNOME pixmap file /usr/share/icons/gnome/24x24/apps/evolution-mail.png

(evolution:3394): Bonobo-WARNING **: Could not find GNOME pixmap file /usr/share/icons/gnome/24x24/apps/evolution-tasks.png

(evolution:3394): Bonobo-WARNING **: Could not find GNOME pixmap file /usr/share/icons/gnome/24x24/apps/evolution-mail.png

(evolution:3394): Bonobo-WARNING **: Could not find GNOME pixmap file /usr/share/icons/gnome/24x24/apps/evolution-tasks.png

(evolution:3394): Bonobo-WARNING **: Could not find GNOME pixmap file /usr/share/icons/gnome/24x24/apps/evolution-mail.png

(evolution:3394): Bonobo-WARNING **: Could not find GNOME pixmap file /usr/share/icons/gnome/24x24/apps/evolution-tasks.png
Comment 8 Matthew Barnes 2009-01-27 12:39:17 EST
Problem should resolve itself after a few package updates.  I'm inclined to close this since I haven't seen any other reports of this.  Any objections?
Comment 9 Ralf Corsepius 2009-01-27 12:49:09 EST
(In reply to comment #8)
> Problem should resolve itself after a few package updates.  I'm inclined to
> close this since I haven't seen any other reports of this.  Any objections?
No, cf. comment #6 - However, I have stopped using evolution, due to on-going issues with it at several spots (IMAP, counter updates, crashes ...), so this doesn't mean much.
Comment 10 Matthew Barnes 2009-02-06 01:24:06 EST
Closing this as CANTFIX, but the problem should work itself out after a couple updates.

Note You need to log in before you can comment on or make changes to this bug.