Bug 472669 - Rhythmbox crashes when trying to transfer song to iPod
Rhythmbox crashes when trying to transfer song to iPod
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-23 04:39 EST by vbuslov
Modified: 2009-03-26 05:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-24 12:35:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fc10 stack dump (26.81 KB, text/plain)
2009-02-13 20:50 EST, Otto J. Makela
no flags Details
fc9 stack dump (10.85 KB, text/plain)
2009-02-13 21:41 EST, Otto J. Makela
no flags Details

  None (edit)
Description vbuslov 2008-11-23 04:39:11 EST
Description of problem:
Rhytmbox crashes with error when trying to drug-n-drop music to iPod.
Error:
(rhythmbox:29010): GLib-GObject-CRITICAL **: g_type_instance_get_private: assertion `instance != NULL && instance->g_class != NULL' failed
76f4a2e5-6ead-4659-64bc0d32-1b464f1c is dumped

Version-Release number of selected component (if applicable):
Rhythmbox 0.11.6

Steps to Reproduce:
1.Open Rhythmbox
2.Drug-n-drop any music file to iPod
  
Actual results:
Program crashes

Expected results:
Song added to iPod

Additional info:
Apple iPod nano chromatic(4th gen) 8gb black
Comment 1 Otto J. Makela 2008-12-02 06:43:18 EST
I can confirm the same GLib-GObject-CRITICAL assertion failure with a f9/i386 system, rhythmbox-0.11.6-2.fc9.i386, and an iPod Shuffle 1G.
Comment 2 Otto J. Makela 2008-12-02 12:29:14 EST
Exactly the same error occurs also with rhythmbox-0.11.6-2.fc9.x86_64 on a f9/x86_64 system.
Comment 3 Otto J. Makela 2008-12-05 05:06:12 EST
This seems to be the same bug as reported in
https://bugs.launchpad.net/ubuntu/+source/libgpod/+bug/199326
where a workaround is suggested: register the iPod with iTunes, and upgrade its software.
Comment 4 Jon Dufresne 2009-02-13 14:19:01 EST
Can you please provide a stack trace; please make sure you have debuginfo packages installed and see http://fedoraproject.org/wiki/StackTraces for more information about getting a useful stack trace. Thank you.
Comment 5 vbuslov 2009-02-13 15:36:38 EST
After I've upgraded iPod with iTunes Rhythmbox is no longer crashes.
Comment 6 Jon Dufresne 2009-02-13 15:43:07 EST
If anyone is still running their ipod with the old firmware can you please attempt to reproduce this bug and get a full stack trace using the instructions on this website: http://fedoraproject.org/wiki/StackTraces

It seems reasonable that some people will be unable or unwilling to install itunes and therefore will still have the old ipod firmware and will run into this bug.
Comment 7 vbuslov 2009-02-13 15:51:50 EST
Well they will have to, because Fedora maintainers not using SVN version of libgpod and only way to sync, for example, podcasts on iPod nano 4th gen is to use iTunes :(
Comment 8 Jon Dufresne 2009-02-13 16:17:59 EST
Ok, Thank you. Until we have the stack trace we are unable to debug this further. I am marking this as NEEDINFO as a request to get the stack trace when the crash occurs http://fedoraproject.org/wiki/StackTraces . If you respond, Please do not remove the NEEDINFO unless you are providing the necessary information.

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Otto J. Makela 2009-02-13 20:50:52 EST
Created attachment 331891 [details]
fc10 stack dump

Meanwhile, I've upgraded to fc10 and rhythmbox-0.11.6-19.r6096.fc10.x86_64 -- turns out this version (for some reason) says it wants to initialize the iPod and then promptly sigsegv's while trying to do it. Unfortunately, in spite of installing >>200MiB of debuginfo files, I am not sure if this is terribly useful as the error produced is something different :-(
Comment 10 Jon Dufresne 2009-02-13 21:27:52 EST
Thank you for the stack trace. Setting status to ASSIGNED. However, At the moment, the Fedora developers are busy fixing other issues and may not have time to work on this one. The best way to make sure your problem will get looked on is to report it to the authors of the program. Most upstream authors use a bug tracking system like bugzilla, and more people who know the code will be looking at the bug report there.

The upstream bug tracking system to use is: http://bugzilla.gnome.org/

You are requested to add the bugzilla link here for tracking purposes.
Please make sure the bug isn't already in the upstream bug tracker
before filing it.

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Otto J. Makela 2009-02-13 21:41:30 EST
Created attachment 331892 [details]
fc9 stack dump

All right, on a fc9 system the originally reported error comes up:

GLib-GObject-CRITICAL **: g_type_instance_get_private: assertion `instance != NULL && instance->g_class != NULL' failed

Let's hope there is everything needed in this file. How come installing debuginfo files cause dependencies to things like a fortran library and a krb5 server?
Comment 12 Bastien Nocera 2009-03-24 12:35:58 EDT
I guess the problem happened because those devices were brand new (see http://bugzilla.gnome.org/show_bug.cgi?id=552617).

Those problems were fixed in F-10 updates and rawhide. If the problem still occurs, please run rhythmbox with "--g-fatal-warnings" so we get backtraces from the first error, not from errors afterwards when it actually falls over.
Comment 13 Otto J. Makela 2009-03-26 05:25:44 EDT
Rythmbox still fell over, bug-buddy automatically opened bug #576830 on the matter.
Comment 14 Otto J. Makela 2009-03-26 05:27:15 EDT
And this of course would be http://bugzilla.gnome.org/show_bug.cgi?id=576830 eg. a gnome bug, not a redhat bug.

Note You need to log in before you can comment on or make changes to this bug.