Bug 472693 - Huge fonts in gdm and gnome with Samsung TV
Huge fonts in gdm and gnome with Samsung TV
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-23 11:27 EST by Andrew.Chatto
Modified: 2009-11-20 02:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-10 10:50:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The Xorg.0.log of the xsession (85.01 KB, text/plain)
2008-11-23 11:28 EST, Andrew.Chatto
no flags Details
xorg.conf that I use to get regular sized fonts (they are poorly rendered, however) (1.35 KB, text/plain)
2008-11-24 10:44 EST, Andrew.Chatto
no flags Details

  None (edit)
Description Andrew.Chatto 2008-11-23 11:27:39 EST
Description of problem:

Huge fonts in gdm and gnome.  I think it may be a problem with EDID

I have a Samsung LN-T4661F TV connected via DVI-HDMI cable.  The resolution is correctly set to 1920x1080 and looks fantastic.  The fonts, however, are HUGE.  If I create a xorg.conf with Option "DDC" "off", the fonts are correctly sized.  However, they are very blocky and hard to read.  Everything else is rendered wonderfully.

I can also call startx -- -dpi 96 and get the same results (good size but horrible rendering of fonts.)  I've read elsewhere (in Ubuntu forums) that this kind of thing is frequently because of bad EDID discovery.  

Version-Release number of selected component (if applicable):

Fedora 10 Preview fresh install, as well as with all updates.
xorg-x11-drv-i810-2.5.0-3.fc10.rpm

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:

Huge fonts, fabulous graphics (the Fedora default blue sun in the background looks amazing.)

Expected results:

regular sized fonts.
Additional info:

I'll attach the Xorg.0.log, 

xrandr looks like this...

Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 1920 x 1920
VGA disconnected (normal left inverted right x axis y axis)
TMDS-1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 160mm x 90mm
   1920x1080      60.0*+
   1400x1050      60.0  
   1280x1024      60.0  
   1280x960       60.0  
   1280x720       60.0  
   1024x768       60.0  
   800x600        60.3  
   640x480        59.9 

----------- The 160mmx90mm looks really suspect.  The size of my monitor is actually 1016x572

The xdpyinfo looks like this...
name of display:    :0.0
version number:    11.0
vendor string:    The X.Org Foundation
vendor release number:    10503000
X.Org version: 1.5.3
maximum request size:  16777212 bytes
motion buffer size:  256
bitmap unit, bit order, padding:    32, LSBFirst, 32
image byte order:    LSBFirst
number of supported pixmap formats:    7
supported pixmap formats:
    depth 1, bits_per_pixel 1, scanline_pad 32
    depth 4, bits_per_pixel 8, scanline_pad 32
    depth 8, bits_per_pixel 8, scanline_pad 32
    depth 15, bits_per_pixel 16, scanline_pad 32
    depth 16, bits_per_pixel 16, scanline_pad 32
    depth 24, bits_per_pixel 32, scanline_pad 32
    depth 32, bits_per_pixel 32, scanline_pad 32
keycode range:    minimum 8, maximum 255
focus:  window 0x2a00008, revert to Parent
number of extensions:    28
    BIG-REQUESTS
    Composite
    DAMAGE
    DOUBLE-BUFFER
    DPMS
    Extended-Visual-Information
    GLX
    MIT-SCREEN-SAVER
    MIT-SHM
    MIT-SUNDRY-NONSTANDARD
    RANDR
    RENDER
    SGI-GLX
    SHAPE
    SYNC
    TOG-CUP
    X-Resource
    XC-MISC
    XFIXES
    XFree86-DGA
    XFree86-DRI
    XFree86-Misc
    XFree86-VidModeExtension
    XINERAMA
    XInputExtension
    XKEYBOARD
    XTEST
    XVideo
default screen number:    0
number of screens:    1

screen #0:
  dimensions:    1920x1080 pixels (508x286 millimeters)
  resolution:    96x96 dots per inch
  depths (7):    24, 1, 4, 8, 15, 16, 32
  root window id:    0x7e
  depth of root window:    24 planes
  number of colormaps:    minimum 1, maximum 1
  default colormap:    0x20
  default number of colormap cells:    256
  preallocated pixels:    black 0, white 16777215
  options:    backing-store NO, save-unders NO
  largest cursor:    64x64
  current input event mask:    0x7a803f
    KeyPressMask             KeyReleaseMask           ButtonPressMask          
    ButtonReleaseMask        EnterWindowMask          LeaveWindowMask          
    ExposureMask             StructureNotifyMask      SubstructureNotifyMask   
    SubstructureRedirectMask FocusChangeMask          PropertyChangeMask       
  number of visuals:    3
  default visual id:  0x21
  visual:
    visual id:    0x21
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff0000, 0xff00, 0xff
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x22
    class:    DirectColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff0000, 0xff00, 0xff
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x58
    class:    TrueColor
    depth:    32 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff0000, 0xff00, 0xff
    significant bits in color specification:    8 bits
Comment 1 Andrew.Chatto 2008-11-23 11:28:39 EST
Created attachment 324436 [details]
The Xorg.0.log of the xsession
Comment 2 Matěj Cepl 2008-11-24 04:40:46 EST
(I don't know why you bother with leaked versions, when we officially leak it on http://fedoraproject.org/get-prerelease ;-))

Anyway, could we get /etc/X11/xorg.conf as well, please?
Comment 3 Andrew.Chatto 2008-11-24 10:44:45 EST
Created attachment 324490 [details]
xorg.conf that I use to get regular sized fonts (they are poorly rendered, however)

I didn't use an xorg.conf.  Fedora 10 does not generate one by default.  I've attached the one I used to try to fix the situation (although I'm no expert at these things.)   If you comment out the 'Option "DDC" "off"' line, you get the huge fonts.  With that line, you get correctly sized fonts that look blocky.

In addition, I didn't know what you meant by 'leaked versions'.  I installed the Fedora 10 preview from the links you showed.
Comment 4 Bug Zapper 2008-11-26 00:49:27 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Adam Jackson 2009-02-10 10:50:25 EST
The DPI thing should be sorted in rawhide, as of 1.5.2-4 or thereabouts.  So, should also be fixed in F10 updates.
Comment 6 Alex Lancaster 2009-11-20 02:11:36 EST
(In reply to comment #5)
> The DPI thing should be sorted in rawhide, as of 1.5.2-4 or thereabouts.  So,
> should also be fixed in F10 updates.  

I still have the problem of large fonts in GDM in Fedora 11.

$ rpm -q xorg-x11-server-Xorg 
xorg-x11-server-Xorg-1.6.4-0.1.fc11.x86_64

I can set them just fine in the actual GDM session, but there doesn't appear to be away to fix in the GDM greeter.  I also have a Samsung LCDTV set very similar to comment #0.

Note You need to log in before you can comment on or make changes to this bug.