Bug 472701 - sox command line parsing appears to be broken
sox command line parsing appears to be broken
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: sox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jiri Moskovcak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-23 15:59 EST by Chris Bagwell
Modified: 2015-02-01 17:48 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-24 06:07:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Bagwell 2008-11-23 15:59:45 EST
Description of problem:
I'm doing some pretty basic testing with sox on my Rawhide box (basically Fedora 10 at todays date).  Some really simple command line options are failing which makes it not very useful for more than audio player/recorder.  Commands with no options will work:

/usr/bin/sox Whatever.ogg test.wav

But if I throw in some command line options then it gets very confused.

/usr/bin/sox Whatever.wav -r 48000 test.wav
/usr/bin/sox formats: can't open input file `48000': No such file or directory

or 

/usr/bin/sox -V -V Whatever.ogg test.wav
/usr/bin/sox: SoX v14.2.0
time:  Nov  5 2008 08:41:31
issue: Fedora release 9.93 (Rawhide) Kernel
uname: Linux tester.testing.com 2.6.27.5-117.fc10.i686 #1 SMP Tue Nov 18 12:19:59 EST 2008 i686
gcc:   4.3.2 20081007 (Red Hat 4.3.2-6)
arch:  1248 48 44 L
/usr/bin/sox formats: detected file format type `vorbis'
/usr/bin/sox formats: can't open input file `-V': No such file or directory


I've tested same operations from upstream package of sox-14.2.0.tar.gz; which is actually about 5 days newer then snapshot in rawhide; and have no problems.

I suspect its as simple as rawhides patch in SRPM is a little large and something may fail the patch operation.  If thats not it, then sox's internal getopt.c happened to be modified same day rawhide snapshot was taken... Its possible a partial commit got caught.

Version-Release number of selected component (if applicable):

sox-14.1.0-5.20081105cvs.fc10.i386
Comment 1 Jiri Moskovcak 2008-11-24 05:37:47 EST
Hi,
thats really weird,because it works for me with the same package version. I got this output and working test.wav. Are you sure you don't have any special (self compiled) libraries or packages installed?

This is output of my sox-14.1.0-5.20081105cvs.fc10.i386

/usr/bin/sox 01.ogg -r 48000 test.wav
/usr/bin/sox effects: rate clipped 234 samples; decrease volume?
/usr/bin/sox sox: test.wav: output clipped 85 samples; decrease volume?
Comment 2 Chris Bagwell 2008-11-24 06:07:27 EST
Yep, its my fault.  Thanks for testing and verifying.

I had /usr/local/lib in my ld.so.conf and custom sox in /usr/local.  Removing /usr/local/lib fixed the problem as /usr/bin/sox was pointing to /usr/local/lib/libsox.so

First time in over 5 years I've noticed a conflict between the two.  Bummer, I can't switch between the two easily to compare behaviors anymore I guess

Note You need to log in before you can comment on or make changes to this bug.