Bug 472725 - rescue fails to find the root partition when the root partition is a logical volume and fstab specifies a LABEL rather that a logical volume.
rescue fails to find the root partition when the root partition is a logical ...
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-24 00:32 EST by Geoff Kingsmill
Modified: 2009-07-10 11:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-19 14:58:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Geoff Kingsmill 2008-11-24 00:32:25 EST
Description of problem:

Anaconda rescue fails to find a linux operating systen when fstab defines a LABEL to an lvm volume.

Rescue prints the following message.

An error occurred trying to mount some or all of your system. Some of it may be mounted under /mnt/sysimage.
Press <return> to get a shell. The system will reboot automatically when you exit from the shell.

#cat /etc/fstab
#/dev/VolGroup00/LogVol00 /                       ext3    defaults        1 1
LABEL=/		 	/                       ext3    defaults        1 1 <--
LABEL=/boot             /boot                   ext3    defaults        1 2
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
sysfs                   /sys                    sysfs   defaults        0 0
/dev/VolGroup00/LogVol01 swap                    swap    defaults        0 0 

#blkid
/dev/mapper/VolGroup00-LogVol01: TYPE="swap" 
/dev/mapper/VolGroup00-LogVol00: LABEL="/" UUID="79a13d4f-4aa8-465e-97d0-d9e739b6a7be" SEC_TYPE="ext2" TYPE="ext3" <--
/dev/sda1: LABEL="/boot" UUID="6591ef26-a4f5-4ab2-a9b8-22c404a7beb7" SEC_TYPE="ext2" TYPE="ext3" 
/dev/VolGroup00/LogVol01: TYPE="swap" 
/dev/VolGroup00/LogVol00: UUID="79a13d4f-4aa8-465e-97d0-d9e739b6a7be" SEC_TYPE="ext2" TYPE="ext3" LABEL="/" <--

blkid shows that /dev/VolGroup00/LogVol00 has the correct volume label of "/".
If I reconfigure fstab to use a logical volume rather than a LABEL (uncomment the first line of fstab and comment the second line) then rescue will works fine.

anaconda.log returns an error saying that fstab has a LABEL=/ but the label could not be found. The full anaconda.log output has been included as an attachment.

#cat /tmp/anaconda.log
.
.
.
12:29:44 DEBUG   : self.driveList(): ['sda']
12:29:44 DEBUG   : DiskSet.skippedDisks: []
12:29:44 DEBUG   : DiskSet.skippedDisks: []
12:29:44 DEBUG   : done starting mpaths.  Drivelist: ['sda']
12:29:44 INFO    : going to mount /dev/VolGroup00/LogVol00 on /mnt/sysimage as ext3
12:29:44 DEBUG   : isys.py:mount()- going to mount /dev/VolGroup00/LogVol00 on /mnt/sysimage
12:29:44 DEBUG   : starting mpaths
12:29:44 DEBUG   : self.driveList(): ['sda']
12:29:44 DEBUG   : DiskSet.skippedDisks: []
12:29:44 DEBUG   : DiskSet.skippedDisks: []
12:29:44 DEBUG   : done starting mpaths.  Drivelist: ['sda']
12:29:44 DEBUG   : adding drive sda to disk list
12:29:44 WARNING : fstab file has LABEL=/, but this label could not be found on any file system
12:29:44 INFO    : trying to mount sda1 on /boot
12:29:44 INFO    : set SELinux context for mountpoint /boot to system_u:object_r:boot_t:s0
12:29:44 DEBUG   : isys.py:mount()- going to mount /dev/sda1 on /mnt/sysimage/boot
12:29:45 INFO    : trying to mount proc on /proc
12:29:45 INFO    : set SELinux context for mountpoint /proc to None
12:29:45 DEBUG   : isys.py:mount()- going to mount proc on /mnt/sysimage/proc
12:29:45 INFO    : trying to mount sysfs on /sys
12:29:45 INFO    : set SELinux context for mountpoint /sys to None
12:29:45 DEBUG   : isys.py:mount()- going to mount sysfs on /mnt/sysimage/sys
12:29:45 ERROR   : 0


I have been able to reproduce this problem on my workstation. Everything works fine if the root device is defined in fstab but fails if a LABEL is used to find the root Logical Volume. LABEL works fine if disk is NOT an LVM volume (eg sda, hda). LABEL only fails when the disk is an LVM volume.


Version-Release number of selected component (if applicable):
All versions in RHEL5 including the the latest RHEL 5.3 rescue cd.

How reproducible:
Reproducible on demand.

Steps to Reproduce:
1. create a root partition on a logical volume and set the volume label
2. define the root partition as LABEL in fstab
3. if you now boot into rescue mode, recue will fail to find the linux partition. 
  
Actual results:
Unable to find and mount the linux root partition

Expected results:
Should be able to find and mount the linux root partition so that you can then do a "chroot /mnt/sysimage". 

Additional info:
Comment 1 Chris Lumens 2009-05-19 14:58:21 EDT
This is fixed in Fedora 11 due to our storage rewrite, which means it will be fixed in the next major release of RHEL.  If you require this fix in an update release of RHEL5, please talk with your partner manager or support representative who will assist in getting this issue raised through the proper channels for getting the scheduling and resources figured out.  Thanks for the bug report.

Note You need to log in before you can comment on or make changes to this bug.