Bug 472729 - NameError: global name 'cdromDevice' is not defined
NameError: global name 'cdromDevice' is not defined
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: YangKun
Lawrence Lim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-24 01:50 EST by YangKun
Modified: 2014-03-25 20:55 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-27 17:58:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dvd-patch-20081124.patch (636 bytes, patch)
2008-11-24 02:14 EST, YangKun
no flags Details | Diff

  None (edit)
Description YangKun 2008-11-24 01:50:00 EST
running dvd on /org/freedesktop/Hal/devices/storage_serial_VA157G63610350
mkdir -p /tmp/hts-dvd-a18sQx/mnt/tests/HTS/hts/dvd
cp -a testinfo.desc runtest.sh dvd.py Makefile /tmp/hts-dvd-a18sQx/mnt/tests/HTS/hts/dvd
install -m 0755 runtest.sh /tmp/hts-dvd-a18sQx/mnt/tests/HTS/hts/dvd
make OUTPUTFILE=/var/log/hts/runs/1/dvd/output.log RUNMODE=normal UDI=/org/freedesktop/Hal/devices/storage_serial_VA157G63610350 DEVICE=hdb TESTSERVER=unknown run
chmod a+x ./runtest.sh ./dvd.py
./runtest.sh
/tmp/hts-dvd-a18sQx/mnt/tests/HTS/hts/dvd/dvd.py
Running ./dvd.py:

  Your CD/DVD device /dev/hdb supports dvdrw, dvdplusrw, dvdr, dvdplusr, dvd 
  We will check these features. 
  You need to prepare following media(disks) for this test: 

    --- one good DVD-RW or DVD+RW disk 


Traceback (most recent call last):
  File "./dvd.py", line 183, in ?
    returnValue = test.do(sys.argv)
  File "/usr/share/hts/lib/hts/test.py", line 252, in do
    return self.run()
  File "./dvd.py", line 142, in run
    self.getMediaChoice()
  File "./dvd.py", line 101, in getMediaChoice
    print "  Your DVD drive /dev/%s supports both %s and %s . " % (cdromDevice,dvdMode,dvdPlusMode)
NameError: global name 'cdromDevice' is not defined
...finished running ./dvd.py, exit code=1
recovered exit code=1
Comment 1 YangKun 2008-11-24 02:10:25 EST
this issue was met on rhel5.3-server-GA-snapshot3-i386, using hts-5.3-3.

it's a name mis-match caused by the cdrom/dvd test split.
Comment 2 YangKun 2008-11-24 02:14:39 EST
Created attachment 324456 [details]
dvd-patch-20081124.patch

simple patch to fix this issue.
Comment 3 YangKun 2008-11-25 02:10:02 EST
the patch dvd-patch-20081124.patch was checked into CVS.
Comment 4 Yan Tian 2009-01-02 21:31:41 EST
Verified "hts run -t dvd" passed without error in hts-5.3-12.
Comment 6 errata-xmlrpc 2009-01-27 17:58:27 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0047.html

Note You need to log in before you can comment on or make changes to this bug.