Bug 472739 - Anaconda crashes with ext4 option in text mode
Anaconda crashes with ext4 option in text mode
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-24 05:08 EST by Arkady L. Shane
Modified: 2009-01-27 09:53 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-27 09:53:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda traceback (36.77 KB, text/plain)
2008-11-24 05:10 EST, Arkady L. Shane
no flags Details

  None (edit)
Description Arkady L. Shane 2008-11-24 05:08:55 EST
Description of problem:
I try to change existing ext3 partition in text mode with enabled ext4 option. So anaconda crashed.

How reproducible:
You must have existing ext3 partition.

Steps to Reproduce:
1. Begin installation with 'ext4 text' options;
2. Do everything till "Partition Type";
3. Select 'Create Custom Layout';
4. 'Edit' any existing ext3 partition;
5. Press 'File System Options' button.
  
Additional info:
Traceback in attachment.
Comment 1 Arkady L. Shane 2008-11-24 05:10:08 EST
Created attachment 324463 [details]
Anaconda traceback
Comment 2 Bug Zapper 2008-11-26 00:50:40 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Ricky Zhou 2008-12-30 19:28:29 EST
I think this is caused when makeFsList is passed a usetypes on line 658 of textw/partition_text.py.  Since fileSystemTypeGetDefault nor request.fstype and request.fstype are in the Listbox, a KeyError occurs on fstype.setCurrent(fileSystemTypeGetDefault()).

Here's a completely untested patch that tries to fix this and clean up the code a bit: http://ricky.fedorapeople.org/anaconda/0001-Fix-behavior-when-makeFsList-is-passed-usetypes-cle.patch
Comment 4 Joel Andres Granados 2009-01-27 06:00:46 EST
FYI,  text mode is probably going away in the future.
Comment 5 Denise Dumas 2009-01-27 09:30:44 EST
Text mode is not going away!  It is changing to provide a standardized, default installation in a manner that is clean for serial consoles etc.
Comment 6 Chris Lumens 2009-01-27 09:53:30 EST
Right, text mode is being simplified.  On my branch for this work, Ricky's patch will no longer apply because that entire block has been removed.  So, I don't believe this is something that will be applicable once my patches are merged in.  That should be happening before F11 Beta.

Ricky - thank you for working on a patch.

Note You need to log in before you can comment on or make changes to this bug.