Bug 472757 - pa_sink_input_request_rewind() assertion hit
pa_sink_input_request_rewind() assertion hit
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
: 475131 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-24 07:24 EST by Zdenek Kabelac
Modified: 2008-12-21 13:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-21 13:08:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zdenek Kabelac 2008-11-24 07:24:28 EST
Description of problem:

I've noticed my coredump directory had two code dump with these backtrace.
Actually I've no idea what was the reason to generate them - but might be, the backtrace will help to fix some problems.

-----

#0  0x00007fdb8fdaeed5 in raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#1  0x00007fdb8fdb0a43 in abort () at abort.c:88
#2  0x0000000000405dc0 in signal_handler (sig=24) at daemon/cpulimit.c:155
#3  <signal handler called>
#4  0x00007fdb920cc6f1 in pa_object_cast (o=0x63e8d0) at pulsecore/object.h:63
#5  0x00007fdb920ccec4 in pa_sink_assert_ref (o=0x63e8d0) at pulsecore/sink.h:157
#6  0x00007fdb920ceef7 in pa_sink_render_into_full (s=0x63e8d0, target=0x7fdb8a5f4f30)
    at pulsecore/sink.c:778
#7  0x00007fdb859ea632 in mmap_write (u=0x623ee0, sleep_usec=0x7fdb8a5f4fe0, polled=false)
    at modules/module-alsa-sink.c:337
#8  0x00007fdb859ed7bc in thread_func (userdata=0x623ee0) at modules/module-alsa-sink.c:1132
#9  0x00007fdb920f3f45 in internal_thread_func (userdata=0x63dff0) at pulsecore/thread-posix.c:72
#10 0x00007fdb900f53da in start_thread (arg=<value optimized out>) at pthread_create.c:297
#11 0x00007fdb8fe6227d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112


---------

#0  0x00007f3555040ed5 in raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#1  0x00007f3555042a43 in abort () at abort.c:88
#2  0x00007f3557369a0f in pa_sink_input_request_rewind (i=0x670120, nbytes=0, rewrite=false, flush=true)
    at pulsecore/sink-input.c:1150
#3  0x00007f3548525293 in handle_seek (s=0x66e7e0, indexw=16758) at pulsecore/protocol-native.c:1239
#4  0x00007f35485254ff in sink_input_process_msg (o=0x670120, code=7, userdata=0x0, offset=0, 
    chunk=0x7f354f886e90) at pulsecore/protocol-native.c:1297
#5  0x00007f3557377b92 in pa_asyncmsgq_dispatch (object=0x670120, code=7, userdata=0x0, offset=0, 
    memchunk=0x7f354f886e90) at pulsecore/asyncmsgq.c:316
#6  0x00007f355737dde4 in asyncmsgq_read_work (i=0x625ae0) at pulsecore/rtpoll.c:698
#7  0x00007f355737c685 in pa_rtpoll_run (p=0x624120, wait=true) at pulsecore/rtpoll.c:326
#8  0x00007f354ac7f924 in thread_func (userdata=0x623f00) at modules/module-alsa-sink.c:1193
#9  0x00007f3557385f45 in internal_thread_func (userdata=0x63e010) at pulsecore/thread-posix.c:72
#10 0x00007f35553873da in start_thread (arg=<value optimized out>) at pthread_create.c:297
#11 0x00007f35550f427d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112




Version-Release number of selected component (if applicable):
pulseaudio-0.9.13-6.fc10.x86_64

How reproducible:
no idea

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bug Zapper 2008-11-26 00:51:13 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Lennart Poettering 2008-12-08 18:03:26 EST
Are you sure those bts are from the current versions of the PA RPMS?
Comment 3 Lennart Poettering 2008-12-21 09:37:32 EST
Oh, and which ALSA sound driver is this?
Comment 4 Lennart Poettering 2008-12-21 12:05:41 EST
I believe I fixed these issues now in upstream commit r03aa91d. I will shortly upload a fixed version to F10 and rawhide.
Comment 5 Lennart Poettering 2008-12-21 12:06:27 EST
*** Bug 475131 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.