Bug 472800 - set_classpath fails if existing CLASSPATH has spaces
set_classpath fails if existing CLASSPATH has spaces
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: jpackage-utils (Show other bugs)
13
All Linux
medium Severity medium
: ---
: ---
Assigned To: Deepak Bhole
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 527323 579113
  Show dependency treegraph
 
Reported: 2008-11-24 13:15 EST by Adam Goode
Modified: 2010-08-05 19:48 EDT (History)
1 user (show)

See Also:
Fixed In Version: jpackage-utils-1.7.5-3.11.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-05 19:48:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix spaces in CLASSPATH (405 bytes, patch)
2008-11-24 16:08 EST, Adam Goode
no flags Details | Diff

  None (edit)
Description Adam Goode 2008-11-24 13:15:19 EST
Description of problem:

When I use set_classpath "jarfile" from a script, and my existing CLASSPATH has spaces, the run command fails. This is probably because of line 70 in 
/usr/share/java-utils/java-functions:

  CLASSPATH=$LOCAL_CLASSPATH:$CLASSPATH



Version-Release number of selected component (if applicable):
jpackage-utils-1.7.5-1.6.fc10.noarch

How reproducible:
Always.

Steps to Reproduce:

$ cat my-script
#!/bin/bash
. /usr/share/java-utils/java-functions

MAIN_CLASS=MyCoolApp

set_classpath "mycoolapp"

run "$@"



$ export CLASSPATH="$HOME/my java project"

$ ./my-script
Exception in thread "main" java.lang.NoClassDefFoundError: project
Caused by: java.lang.ClassNotFoundException: project
Comment 1 Adam Goode 2008-11-24 16:08:08 EST
Created attachment 324538 [details]
Patch to fix spaces in CLASSPATH
Comment 2 Bug Zapper 2008-11-26 00:52:45 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Adam Goode 2009-10-05 19:27:56 EDT
Still broken in jpackage-utils-1.7.5-3.8.fc12.noarch.
Comment 4 Bug Zapper 2009-11-16 04:38:33 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Adam Goode 2009-11-20 19:48:45 EST
Still broken, and there is a patch. Could this be fixed?
Comment 6 Bug Zapper 2010-03-15 08:10:47 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Fedora Update System 2010-06-28 17:58:07 EDT
jpackage-utils-1.7.5-3.11.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/jpackage-utils-1.7.5-3.11.fc13
Comment 8 Deepak Bhole 2010-06-28 17:59:00 EDT
jpackage-utils-1.7.5-3.11.fc13 should fix this issue. Please let me know if you still encounter it.
Comment 9 Fedora Update System 2010-06-28 19:37:10 EDT
jpackage-utils-1.7.5-3.11.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update jpackage-utils'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/jpackage-utils-1.7.5-3.11.fc13
Comment 10 Adam Goode 2010-06-29 09:49:36 EDT
Seems to work, thanks!
Comment 11 Fedora Update System 2010-08-05 19:48:22 EDT
jpackage-utils-1.7.5-3.11.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.