Bug 472830 - Anaconda crashes in Xen PV install
Anaconda crashes in Xen PV install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-24 17:23 EST by Jeremy Fitzhardinge
Modified: 2009-05-12 21:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-12 21:34:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Fitzhardinge 2008-11-24 17:23:15 EST
Description of problem:
When doing a PV install of a x86_64 Xen guest, anaconda crashed.  May be due to the fact that the domain has no network devices configured.

Version-Release number of selected component (if applicable):
11.4.1.53

How reproducible:
Always.

Steps to Reproduce:
1. Perform Xen PV install
2. Select partition layout, etc
3. Crash after formatting filesystems
  
Actual results:
Anaconda crashes with:
anaconda 11.4.1.53 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.5/site-packages/snack.py", line 751, in setCurrent
    self.w.checkboxtreeSetCurrent(self.item2key[item])
  File "/usr/lib/anaconda/textw/netconfig_text.py", line 123, in run
    self.interfaceList.setCurrent(0)
  File "/usr/lib/anaconda/text.py", line 501, in enableNetwork
    ret = w.run()
  File "/usr/lib/anaconda/yuminstall.py", line 970, in doBackendSetup
    if not anaconda.intf.enableNetwork(anaconda):
  File "/usr/lib/anaconda/backend.py", line 251, in doBackendSetup
    if anaconda.backend.doBackendSetup(anaconda) == DISPATCH_BACK:
  File "/usr/lib/anaconda/dispatch.py", line 204, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 127, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py", line 739, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 954, in <module>
    anaconda.intf.run(anaconda)
KeyError: 0


Entering debugger...
> /usr/lib64/python2.5/site-packages/snack.py(751)setCurrent()
-> self.w.checkboxtreeSetCurrent(self.item2key[item])
(Pdb) 


Expected results:
Complete install.

Additional info:
Comment 1 Bug Zapper 2008-11-26 00:53:18 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Chris Lumens 2009-02-09 11:56:01 EST
I believe this should be fixed by now.  Can you please retest with rawhide and verify?  Thanks.
Comment 3 David Cantrell 2009-05-12 21:34:29 EDT
Unable to reproduce this problem using the latest rawhide.

Note You need to log in before you can comment on or make changes to this bug.