Bug 472856 - Bogus location values disrupt 2-finger scrolling
Bogus location values disrupt 2-finger scrolling
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-synaptics (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-25 01:35 EST by Ignacio Vazquez-Abrams
Modified: 2008-12-07 18:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-05 06:25:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ignacio Vazquez-Abrams 2008-11-25 01:35:30 EST
Using synclient -m, I see that my touchpad returns values for x and y of 1 and 5855 respectively when two-finger scroll has been released. This is considered hard left and down, even though this is "lefter than left" and "downer than down" (LeftEdge and BottomEdge are 1632 and 4281 respectively). This leads to the window scrolling all the way to the bottom left on occasion due to some race somewhere. The driver should disregard these invalid values instead.

xorg-x11-drv-synaptics-0.15.201.fc10.x86_64
Comment 1 Peter Hutterer 2008-11-25 19:07:45 EST
Sounds a lot like
http://lists.freedesktop.org/archives/xorg/2008-November/040592.html

Just give me a bit of time to package that up.
Comment 2 Peter Hutterer 2008-12-04 18:13:06 EST
Please try the package from http://koji.fedoraproject.org/koji/buildinfo?buildID=73122
Comment 3 Ignacio Vazquez-Abrams 2008-12-05 05:42:00 EST
Excellent, scrolling is almost rock solid. It feels like the acceleration characteristics have changed, but that might be me.
Comment 4 Peter Hutterer 2008-12-07 18:00:01 EST
No, you're right on that. All the accel settings are now autoconfigured based on the device's dimensions so it may be that your settings have changed slightly.
We tried to stick as close as possible to the original defaults though to minimise impact.

Note You need to log in before you can comment on or make changes to this bug.